Some point features don't draw in new Map Viewer, but they do draw in the Visualization tab, in Map Viewer Classic, ArcGIS Pro.

766
1
03-22-2022 05:48 PM
HollyTorpey_LSA
Occasional Contributor III

Greetings!

I am using a feature service hosted in Enterprise and shared by reference to ArcGIS Online via a distributed collaboration. The feature service is shared with Everyone. I published the feature layer to Enterprise from ArcGIS Pro.

When I add the feature service to ArcGIS Pro or Map Viewer Classic (on AGO), all the features draw as expected. They are also visible in the Visualization tab of the feature service's Item Details page on AGO, and in both Map Viewer Beta and Classic on Enterprise 10.9. However, when I add it to the new Map Viewer in AGO, some of the features don't draw. It doesn't matter if I view them in my existing map with other layers or in a new one all by itself.

The map (saved in the New Map Viewer on AGO) is being used in a Dashboard on AGO, and interestingly, the features are all accounted for in the Dashboard's table element even though they are not visible on the map. The table element is pulling data from the layer in the map element, not from the standalone layer.

I have tried using the default location only symbology in place of the original symbology, but the features still do not draw. There is no error message, no yellow triangle in the corner, and no filter in place. It's not a feature service view, so view definition is not an issue. 

I tried overwriting the layer from Pro, same result.

Any ideas?

Thanks in advance!

- Holly
Tags (1)
0 Kudos
1 Reply
EdmondKuto
New Contributor

I had a similar issue but drawing point layers on ArcPro. They could only zoom up to a certain extent without any restrictions on extent limitations. I fixed the issue by using the "Fix Geometry" Tool and the layers could draw at all extents. I hope this helps.