Select to view content in your preferred language

/Sharing/Proxy" issue

4698
4
05-04-2015 01:53 AM
StineSkaarup
New Contributor

I am currently creating a WMTS server and I have tried to connect to it through ArcGis online. I also tried to create a service that could provide single tiles by supplying urls directly and this worked (The tile layer option). My problem occurs when I connect as "A WMTS OGC Web Service". In this case I cannot get any contact to my server. It seems that ArcGis uses a proxy. By monitoring the traffic I could see the following:

Inline image 1

The problem seems to be the "/sharing/proxy?" part that is added by ArcGis. Do you know a work-around  for this issue or how to set up the server correctly so it becomes possible to communicate with ArcGis.

Any help is much appreciated.

0 Kudos
4 Replies
KellyGerrow
Esri Frequent Contributor

Hello,

What browser are you using where you receive the error? Try using IE 10 or above or Chrome/Firefox.

Also, if possible, please share/message me your WMTS URL.

Thanks,

Kelly

0 Kudos
StineSkaarup
New Contributor

Thanks for the quick reply.

I am already using IE11 and also tested with Chrome/Firefox, but it didn't solve the issue.

At this point I am just trying to reach the server from ArcGis Online and still haven't really implemented any real functionality for the WMTS. So the issue for me is currently simply to be able to reach the server.

You could try with the following URL and request: http://10.10.180.20/WMS13?request=gettile

This request should return a single tile.

The image from the first post wasn't inserted correctly, but I have inserted it here (note this is an old url):

fiddlerDump1.png

The issue seems to be the requested url, which somehow has been prepended with "sharing/proxy" (this is obviously an error as http should be at the beginning of the url). The host is also ssh.maps.arcgis.com. When requesting tiles directly with the "tile layer option" the host was simply 10.10.180.14/WMS13, which worked.

A theory I have is that you have to use ArcGIS Server to connect with ArcGis online? While googling the issue a lot hits concerning ArcGIS Server came up and no one seemed to have an external server without the use of ArcGIS Server.

0 Kudos
KellyGerrow
Esri Frequent Contributor

HI Stine,

I noticed that the URL for the WMTS that has been shared is an internal  URL, and is not accessible outside of your network. Currently, WMTS must be an external service in order to be consumed in the map viewer as documented in the following help link.

Do you have a version of this WMTS that can be accessed from other networks?

Thanks,

Kelly

0 Kudos
StineSkaarup
New Contributor

Hi Kelly,

the problem is as you noticed, that the URL is private. I thought that this wouldn't be a problem, because connecting with the sever worked with the tile layer service. I haven't got a url that can be accessed from outside our network yet and will try a different approach for testing the service on my own network.

Thanks for the help,

Stine

0 Kudos