Select to view content in your preferred language

Selecting Feature in Web Scene Layer Shows Selection Outline Underground

1589
12
Jump to solution
08-03-2023 07:07 AM
GBacon
by
Occasional Contributor

In both local and global web scenes, the selection of a building feature results in an underground outline of the feature that is distracting to the user. Is there a way to prevent this?

GBacon_0-1691071592236.png

 

1 Solution

Accepted Solutions
Gertvan_Maren1
New Contributor III

Hi, 

How are the buildings symbolized in Pro? Are they building footprints with a procedural rule? If so, then turn off the solid stroke renderer before creating multipatches:

Gertvan_Maren1_0-1691531607327.png

 

View solution in original post

12 Replies
AndreasUlmer
Esri Contributor

Selection highlight has a "shine-through" effect to make it visible even if (partially) occluded. This is by design.

In your specific case, it looks like the building has a single bottom plane underground. Can you check if this is the case (e.g. by hiding terrain/ground, or lifting up buildings with elevation offset)? If that's the case then the highlighting behavior would be as expected.

If there isn't a bottom plane I cannot see an obvious other issue just from the picture. Would it be possible to share this scene (or a reduced subset that shows the problem) publicly so we can have a look? So far we were not able to reproduce this case, and we might need to have a closer look at the actual scene / actual data to be able to track this down further.

0 Kudos
GBacon
by
Occasional Contributor

Thanks, Andreas.

Here is the scene: ESRI Test (arcgis.com)

 

 

0 Kudos
AndreasUlmer
Esri Contributor

After hiding the Lidar Point Cloud, and making ground transparent (in basemap widget) we can see that all buildings indeed have an underground "footprint" polygon (or rather a polygon outline).
All parts of a feature get selected and highlighted, i.e. the behavior you see is expected. There is no option to selectively control the highlighting within a feature.

Can you recreate the features (the Building SceneLayer) to not include the underground footprint part?

 

AndreasUlmer_0-1691082072814.png

 

0 Kudos
GBacon
by
Occasional Contributor

How do I do that? Is it during the publishing process in ArcGIS Pro? I've never seen this behavior before. I thought maybe you meant there was an accompanying feature layer causing this, but these are the only items created when I published the multipatch: 

GBacon_0-1691086915346.png

 

0 Kudos
AndreasUlmer
Esri Contributor

Not a Pro expert, but AFAIK the publishing process will not add these, they must be there before publishing already.
Check data in Pro before publishing, pretty sure they show up there as well (though might not be underground). My assumption is your data contains these footprints. Or they get added somehow in the creation process.

0 Kudos
GBacon
by
Occasional Contributor

The building outlines do show up underground in Pro. 

 

GBacon_0-1691149433798.png

I resaved the scene above to highlight the building shown below as it does not cast an outline, web scene or Pro scene, when selected. This building was created manually in Pro using editing tools while all others were created using the 3D Basemap Solution. This building was added to the multipatch output from the solution and then published. Why does that make it behave differently in a web scene and Pro?

GBacon_0-1691151466393.png

@RussRoberts 

0 Kudos
RussRoberts
Esri Notable Contributor

This looks like a difference in the output of using the solution tools vs. manual generation.  The footprints look to be apart of the multipatches. The coloring and styling of the footprints matches the building type color value, if you enable edges the footprints also get the edges at the same time.  I would ask this question in the solutions forum. 

0 Kudos
GBacon
by
Occasional Contributor

Thanks, Russ.

I opened a support ticket and will try the solutions forum if that doesn't answer my question.

0 Kudos
Gertvan_Maren1
New Contributor III

Hi, 

How are the buildings symbolized in Pro? Are they building footprints with a procedural rule? If so, then turn off the solid stroke renderer before creating multipatches:

Gertvan_Maren1_0-1691531607327.png