Removing datasets from groups...

3631
6
04-27-2014 02:15 AM
GaëtanLAVENU
Esri Contributor
Hi,

When I remove some items from a group (that is enabled for Open Data) in my ArcGIS Online portal, it seems that the datasets are not removed from my Open Data web site. It's like removing items from a group doesn't rebuild index in ArcGIS Open Data. I've tried to remove the group, save my ArcGIS Open Data settings and then add it again, but nothing seems to be updated. Any idea ?

Regards,

Gaetan LAVENU
Esri France
Tags (2)
0 Kudos
6 Replies
DavidTong
New Contributor
Hi,

I'm having the same issue. Feature layers added or removed from the Open Data group are not being reflected in the app. What drives a re-index of the data in that group?

Thanks,

Dave
0 Kudos
SimonLiu
New Contributor III
I've encountered a related issue: adding an item to an Open Data group also doesn't trigger the Open Data portal's index to refresh. I waited 15 minutes and nothing happened.

One work-around I've found is to temporarily create a second Open Data portal from the group, which seems to force the index in both portals to refresh. You can then delete the second portal. Obviously, having to do this every time you want to add new items isn't ideal!
0 Kudos
AndrewStauffer
Esri Regular Contributor
This appears to be a known issue with unsyncing the items shared in a group to Open Data. We are looking into a fix for this.

As for how to re-sync, you can simply just save your site again and it should index your items.

Thanks,
Andrew
0 Kudos
ReetaOjala
New Contributor II
Hey,

I had heaps of issues with this at first, but simply removing the group from the web site and saving and then adding it again to the site has had positive results! As well as changing the setting of the data to be not public has helped as well.

BR,

Reeta Ojala
Esri Finland
0 Kudos
JamesMilner
New Contributor
Hello,

I've recently been setting up a open data portal and have had similar issues to the ones described by users in this thread. I have been unable to remove layers from the portal even if they are delete and removed from the open data group. I have tried:

�?� Changing the layout of the site and saving
�?� Removing the open data group from the site, saving and then reading the group and saving once more.
�?� Disabling �??Designated open data group�?? then re-enabling
�?� Turning off the open data group
�?� Removing layers from the open data group and resharing them to the group
�?� Renaming the open data site
�?� Recreating the Open Data group
�?� Recreating the open data site (with a new name)

None of which seem to make the delete layers disappear. Furthermore earlier I was having trouble adding layers as they were not appearing, and the only solution appears to be to delete the group, delete all the services and republish them (obviously not ideal). I understand that this bug is on your radar, but I just thought I would give my experience with it. Is there any ETA on a fix for this issue?

Thanks
RachelFrischeisen
New Contributor III

I believe this is still an issue. I have tried most of the suggestions here. Some seem to work (sometimes), other times they are not effective. It's hit or miss. Maybe it occurs after a certain combination of removing/re-sharing/saving/etc. The redesign of the Open Data Portal editor added an "Update Index" button (under Data Reports) to identify broken feature services, etc. but does not seem to work properly, as the services I had removed still show up in the portal.

If anyone out there has another solution or idea, let me know.

0 Kudos