Select to view content in your preferred language

Overwrite feature layer collection not working as expected

492
2
06-22-2023 09:33 PM
Labels (1)
MartinPeak
New Contributor II

I have a common workflow to update AGOL content from local file geodatabase by overwriting the feature layer.

Recently im noticing that the row counts between the local fgdbs and the AGOL feature services are different, and there's no clear reason for it. In one case i could run a repair geometry on the layer which fixed it, and in others that has no affect and theres no clear reason when looking at the schema or the data content. It happens over multiple fgdbs aswell. 

i have already spent multiple hours analysing multiple datasets but i wonder is there any known issues that would be affecting the overwrite feature layer function?

I mostly carry out these updates through the arc gis api for python, which returns that a successful overwrite has occurred.

0 Kudos
2 Replies
sarah_maisel
Esri Contributor

Hi @MartinPeak ! Thanks for posting and I'm sorry to hear you're having issues. Is there a reproducible dataset you could share with me so we can try to repro? We have not had luck with sample data.

Alternatively, if you have Support maintenance, I'd be happy to get a case created for you so an analyst can help you get to the bottom of it. 

 

0 Kudos
JamesNurse
New Contributor

Hey we're also reproducing this, was any update done on this?

Obviously it looks like this is a duplicate of https://community.esri.com/t5/arcgis-api-for-python-questions/overwrite-feature-layer-python-api/td-...

 

0 Kudos