Select to view content in your preferred language

On Premise Feature Service Uneditable In Web Map Viewer

829
5
Jump to solution
03-28-2023 01:18 PM
Labels (2)
John_Spence
Occasional Contributor III

Is anyone running into this aside us?

  • On premise hosted services (Stand alone ArcGIS Server site 10.9.1 w/ latest patches)
  • Service is published by ArcGIS Pro 3.x
  • On premise MS SQL Server, SDE Database (v 10.8.1)
  • Not versioned or configured for offline.
  • Editable Feature Service (hosted on premise) in ArcGIS Online Web Map
  • Web Map is uneditable.
  • What does work is...
    • Editing via ArcGIS Pro
    • Editing via Classic Map Viewer
    • Editing via Field Maps
    • Editing in ArcGIS Portal (10.9.1) w/ the current map viewer.

Error is as follows - 

John_Spence_0-1680034497558.png

 

0 Kudos
1 Solution

Accepted Solutions
John_Spence
Occasional Contributor III

Hi folks,

Turns out this is now a bug. BUG-00015717.

No word on when it will be resolved, but figured there is someone out there with a similar issue. 🙂

View solution in original post

5 Replies
jcarlson
MVP Esteemed Contributor

I would open up your browser's Network tab and watch what kind of POST it's making to the service when you try to edit. Maybe make an edit in the classic viewer and compare the two?

- Josh Carlson
Kendall County GIS
0 Kudos
John_Spence
Occasional Contributor III

All good thoughts here. Yes, that was done and the calls are different. What's odd is that the viewer is doing something dissimilar to classic or Field Maps.

0 Kudos
jcarlson
MVP Esteemed Contributor

A difference from classic I'd expect, but Field Maps, that's interesting... What about one of the Instant Apps built on top of the new viewer? Some of them include editing tools.

Is it only this layer, or do you see it with other registered services? Are there null values in integer fields? I have no end of headaches with the way certain (but not all) parts of the Esri-verse handle null integers.

- Josh Carlson
Kendall County GIS
0 Kudos
John_Spence
Occasional Contributor III

Good morning Josh,

I was able to dig into this further, examining the payloads going up, etc....

The difference between the classic viewer, Portal (10.9.1) viewer, and ArcGIS Online's viewer is that the new viewer is adding "returnServiceEditsOption=originalAndCurrentFeatures" to the string that pushes the edits.

For ArcMap published services....no issue. For ArcGIS Pro published services, its an automatic fail w/ the code...

"error":"code":500,"extendedCode":-2147467259,"message":"Unable to complete operation.","details":["Error: Combination of parameters rollbackOnFailure = false & returnServiceEditsOption = originalAndCurrentFeatures for applyEdits operation is not supported."]

The classic viewer does not have it, nor Portal, so I am assuming it was the recent updates to the viewer which causing the issues.

WRT using Instant Apps, I have not tried that route yet, but passed it over to the analyst who is experiencing the issue. For the time being, they are working around the issue using Field Maps. I offered to pull this into Portal for them, but there is some hesitancy there for the moment.

Fun stuff. Hope no one else is experiencing this issue.

 

 

0 Kudos
John_Spence
Occasional Contributor III

Hi folks,

Turns out this is now a bug. BUG-00015717.

No word on when it will be resolved, but figured there is someone out there with a similar issue. 🙂