New SSL certificate causes problems in ArcGIS Online

10-02-2020 02:05 AM
Occasional Contributor II


The certificate of our ArcGIS Enterprise server will expire in a few days, so I renewed the certificate, importing it into the ArcGIS Server admin environment, and selecting the new certificate in the IIS Bindings. This all worked fine. Then our IT infrastructure provider replaced the certificate on the Netscaler, our portal to the internet. After this though, all our published feature layers in ArcGIS Online were nog working anymore. I tried to publish a 'new' feature layer in ArcGIS Online, and that worked. Rebooting the ArcGIS server did not help.

So we had to undo the change on the Netscaler, and then everything worked again, including the newly published feature layer.

So now I am wondering what I could be missing. I would not like to have to republish and reconfigure all our feature layers to ArcGIS Online, obviously. This would cost me several days work. Also this would probably mean that offline webmaps cannot be synced anymore.

Hopefully anyone can give me some ideas.

Joris Frenkel, Staatsbosbeheer, the Netherlands

0 Kudos
0 Replies