Select to view content in your preferred language

Multiple custom point symbols, directional symbology, issue uploading as web layer.

744
5
03-21-2023 02:59 PM
vg11
by
Occasional Contributor

Trying to share map from Pro onto Online. I have been sharing layers as web layers, but have run into issue. I will attach images for reference.

1) One layer (water valves layer) could not publish due to 'staging failed' issue. I need to be able to upload layer to map online and can't due to staging failure. Screenshot attached. 

2) I need to be able to upload multiple customs symbols for point symbology. They are shown in pictures uploaded, water valves and meters. I know in AGOL you can upload one custom symbol for a single point value, but I have unique values and multiple symbols. When I added 'meters' layer, the symbols matched but were the size on a pen mark. Super tiny and I couldn't edit it until I changed them completely. 

3) Symbology representing flow, pictured in image labeled 'sewer example.' In pro, we do not have any attribute dictating direction. It was drawn in like that. I uploaded this layer to AGOL and lost direction and didn't have any way to show it. There was an option of rotation but it is based on attribute.  

4) Is there ANY other way I can share Pro map? I am hating AGOL and would like a way to share my map with exact same symbols and everything. I will attach an image on my Pro map to what has been translated to AGOL. My company needs access to a map that looks exactly like mine, and AGOL is not capable of that. 

Any tips are appreciated. 

0 Kudos
5 Replies
RussRoberts
Esri Notable Contributor

Are you able to share a Pro package and I can see if I can reproduce the publishing issues? You can share it to a group and invite russell_jsapi to it. 

Some other questions: 

- Are you opening it in Map Viewer or Map Viewer Classic?

- Are you publishing the map with "Use symbol types compatible with all clients " checked?

- What version of Pro are you using.

0 Kudos
vg11
by
Occasional Contributor

I am using Map Viewer but also tried Classic, to no avail.

I have done both unchecked and checked, neither works. Although, there seemed to be a smidge more flexibility when the box was checked. However, the symbology was still a tiny point and couldn't maintain our custom point symbols. 

ArcGIS Pro 3.1.0

I tired to share as a package and ran into 10 error's saying data source cannot be found and then it crashed on me. 

I was able to get water valves layer and avoid the staging failed issue, I just created a feature class from the layer and that seemed to help. I will try to share as package again. 

Is sharing a package a viable way to share my map with my organization or do they need Pro to access it? Thanks for your help and if I get a package ready I will include you. 

0 Kudos
vg11
by
Occasional Contributor

Just kidding ((((: when I exported water valve layer as feature class, I lost quite a few of my points. So still stuck on staging failed issue. Should I be making a project package or a map package? I am not familiar with the package tool. When I tried to make a map package I received a ton of errors, mainly 'layer's data source in inaccessible'

0 Kudos
RussRoberts
Esri Notable Contributor

Either package would work for me I would primarily be looking at any lost or dropped symbology. Looking at the error in the logs again it looks like a data source might be the issue and not have a valid connection. 

The package will be a downloadable file so it wouldn't be used in any online viewers and have to be used in Pro.  

 

Looking at the staging error again the issue might be with a data connection issue along with if making a package failing: https://pro.arcgis.com/en/pro-app/latest/tool-reference/tool-errors-and-warnings/001001-010000/tool-...

You might want to contact support or post in the ArcGIS Pro community . 

0 Kudos
vg11
by
Occasional Contributor

I ended up exporting as a shapefile from ArcMap and that seemed to work. For some reason when I tried to export from Pro I would get a 'staging failed' error or exporting as a feature class, I lost all my points. But it worked easily from ArcMap!

0 Kudos