Select to view content in your preferred language

Missing layers when sharing web scene from ArcGIS Pro to ArcGIS Online

578
3
05-01-2023 10:18 PM
zdgra
by
New Contributor III

I have a local scene in ArcGIS Pro that has 5 raster layers and 5 ground layers.

 

web-scene-arcgis-pro.png

 

 

When I shared it as a web scene to ArcGIS Online, only 1 of my raster layers shows up while all of my ground layers show up.

 

web-scene-arcgis-online.png

 

I tried it again: when I first shared, I noticed that I had one raster layer checked and one ground layer checked, so I shared again with all of the raster layers and ground layers checked, thinking that might have been the problem. The same thing happened: only one of the raster layers showed up.

Here's how the job queue looked:

 

job-queue-arcgis-pro.png

 

What I'm getting from this is that all of the elevation/ground layers are being published, but only one of the raster layers (at the bottom) is being published. And does WTL mean the raster layers are being converted to tile layers?

---

Why is this happening? And what can I do about it?

0 Kudos
3 Replies
RussRoberts
Esri Notable Contributor

I would recommend posting this in ArcGIS Pro community.

But a couple of questions: 

When you look at the sharing dialog do you see the multiple tile layers?

Can you rename the layers just to help identify if a layer is being dropped? 

Do you see any warnings in the analyzer?

Does your account have access to publish hosted imagery layers instead of tile layers?

https://pro.arcgis.com/en/pro-app/latest/help/sharing/overview/publish-hosted-imagery-layers.htm

0 Kudos
zdgra
by
New Contributor III

Interestingly, all of my raster layers are getting grouped under one tile layer, as you can see here.

 

layer-outline-arcgis-pro.png

 

There are no warnings besides letting me know which coordinate system my layers are using.

I'm not sure if my account have access to publish hosted imagery layers. How can I check that?

0 Kudos
RussRoberts
Esri Notable Contributor

2 ways

Under your Settings for your profile look under Licenses

RussRoberts_1-1683116130410.png

 

or

 

The admin for your organization can check if your account has a role with the ability to publish these layers is enabled.

RussRoberts_0-1683115685508.png

 

0 Kudos