Map viewer clustering labels not displaying with web application

975
5
03-24-2023 04:50 AM
Labels (2)
cat206
by
Occasional Contributor II

I have used the Aggregation - clustering in the map viewer, which displays the amount of events with labels. However, the labels do not show in the web application. I have tried saving the layer, but it only saves as a feature layer and does not give me the option to publish it as a hosted feature layer. Can anyone help please? 

 

 

5 Replies
RussRoberts
Esri Notable Contributor

What web app are you using? The labels in clustering is not supported in applications Web AppBuilder and Map Viewer Classic. Using Instant Apps, Experience Builder and Dashboards would support this aggregation labeling. 

JacquieKovarik
New Contributor III

Hi @RussRoberts ,

I am trying to get clustering to display in the Attachment Viewer Instant App but it will not work. I have tested recreating a new Attachment Viewer Instant App with no luck. It does, however, work in the Basic Instant App. Is this expected behavior?

 

Thanks,

Jacquie

0 Kudos
RussRoberts
Esri Notable Contributor

It looks like attachment viewer does not have an experience in the viewer to expose the clustered features and show the attachments. I would recommend getting attached to this support ticket BUG-000143637

0 Kudos
cat206
by
Occasional Contributor II

Ah ok, that's a real shame! I created the clustering from Web viewer but the app is made with Web AppBuilder (tab theme), as it's are easier and quicker to build an application with the widgets i need. Thanks for the help

0 Kudos
RussRoberts
Esri Notable Contributor

Yup the older clients will not support this and have certain clustering limits new apps do not have. WAB also has a retirement plan.

https://www.esri.com/arcgis-blog/products/web-appbuilder/announcements/arcgis-web-appbuilder-roadmap...