layers keep getting added to webmap from last webmap opened

445
5
11-02-2020 10:18 AM
KevinMacLeod3
MVP

If you open a webmap it seems to add stuff from the last webmap, as a new 'default'. So for example it adds layers from the last webmap I had open in to a new webmap. This seemed to start happening over the summer, after the "existing webmap" state seemed to become a thing. Anyone else seeing this? How can I get rid of it? It's a bizarre default behavior that I do wish to happen. If I want to add a layer I will add a layer as usual.

0 Kudos
5 Replies
SamButler2
Esri Contributor

Hi Kevin, 

You can add layers to a new Web Map by selecting the drop down next to "Open in Map Viewer" and selecting "Add to new map" as shown in the screenshot below. 

Regards, 

Sam 

0 Kudos
KevinMacLeod3
MVP

Hi Sam, thank you for your reply. I had noticed this after the AGOL update earlier this year. Oddly though this time... AGOL was adding layers from webmap 1 in to webmap 2 which was already an existing webmap. Both were already existing. Very confusing and unexpected behavior. Perhaps I I came across another bug. I'll show support. In general; a safe default would be a New Map that is blank, if people click the Map button. Currently it seems to open the last map and something about unsaved changes. I would prefer the previous behavior. More logical, expected; and less error prone when working with production maps.  When creating a new document in essentially any program on a computer the long-standing convention is a new blank document. (no intermingling of other documents or their data)

0 Kudos
by Anonymous User
Not applicable

Not sure I fully understood the issue but the "existing" web map has been in AGO for years. If you have a new map and add layers to it, save it, don't save it, etc., that is your "existing" map. If you go to a layer in my content and click add to map, it adds it to your currently open web map. If you select add to new web map, it loads just that layer.

Now if you are saying you have two separately saved web maps, map 1 and map 2, and you open map 1, mess with it, and then go to my content and load map 2, a popup should appear asking if you want to open map 2 and wipe out any "unsaved changes" in map 1. But I'm 99% sure opening map 2 would not just add layers to map 1 just because you previously had it open. But maybe I'm missing something here.

0 Kudos
KevinMacLeod3
MVP

Hi Nathan, you're right; and yes the Add to vs New makes sense, but it was happening an existing webmap. Perhaps a weird corner case bug. It was two webmaps. Which just had basemaps in them (I made custom ones in the Styler) I re-created them and haven't repro'd it since. I'll keep an eye out for it and show support if it happens again.

0 Kudos
by Anonymous User
Not applicable

Ah okay, that is strange.