Labels in Tile Layer are not visible in AGOL

538
3
09-18-2017 03:09 AM
AlessandroValra
Occasional Contributor III

I have created a Tile Layer from a Tile Package (tpk) created from ArcMap 10.4.1.

The mxd from which the TPK was created from has a point layer with labels turned on.

These labels have a scale range which shows them only when zoomed out beyond 1:5000.

I can confinrm my labels appear only when zooming in more than 1:5000 in the mxd.

I cannot see them in AGOL however. I tried different ways of publishing the Tile Layer, but none solved the issue so far:

  1. creating the TPK using Share As->Tile Package and uploading through AGOL "Add Item from computer" and then publishing it as Tile Layer.
  2. creatig the TPK using "Manage Tile Cache" and "Export Tile Cache" and then the same as in previous point.
  3. setting the scale range to "same as layer" and setting the layer visibility to 1:5000

All I get is a Tile Layer with everything showing fine except I don't see any label at all.

I am on Italian language setting in my AGOL. Could this be the problem? I had another issue (not related to this one) which was caused by the Language setting.

Will try to change language and will come back to this if I resolve.

Thanks in advance for any help.

0 Kudos
3 Replies
AlessandroValra
Occasional Contributor III

I attach the tpk (in the original post) and the link (here) to the tile service to hopefully give someone the possibility to further investigate on this problem. Maybe I am just missing something simple, but i just can't really tell why labels are not showing up. I also tried with another mxd with a different layer but with the same settings and the labels do show up... Hope this improve the chance to get help. thanks in advance!

link: https://arcg.is/1ey1mT 

0 Kudos
MikeMinami
Esri Notable Contributor

I've downloaded your TPK and used the GP Tool Extract Package in ArcMap to examine your TPK.  The tiles don't have labels in them, which is what I expected as tiles in TPKs are built in desktop. So, we can eliminate publishing to AGOL as a problem. For some reason, the tiles were not drawn when the tiles were created. It looks like the the layer definition indicates that labels should be drawn.  Having said the above, I don't know why labels were not drawn. Maybe there's some configuration step you're missing? 

MIke

AlessandroValra
Occasional Contributor III

Thanks Mike Minami‌ for the feedback. Indeed, I saw from the rest page of the tile service that labels should be drawn, and it is good that you pointed out it is not a problem related to AGOL. I will further investigate into the problem and come back to this thread with some news.

0 Kudos