Is it possible to have a vector tile package and a map tile package in a basemap on ArcGIS Online web map?

660
6
Jump to solution
06-12-2019 05:39 AM
Col_Forbin
New Contributor III

I have a vector tile package with a transparent background that I published to AGO.  I also have a map tile package with a raster hillshade layer that I shared from ArcGIS Server to AGO.  I want to create a web map in AGO with both the vector map and the hillshade tile layer in the basemap layer.  But I want the hillshade layer below the vector map.  I can't seem to drag the hillshade layer under the vector layer in the web map viewer in AGO.  I went into ArcGIS Online Assistant and modified the JSON so that the hillshade layer is below the vector layer, and saved it.  When I then view the web map, they appear correct, but when I zoom in or out, just the hillshade layer zooms independently of the vector layer.  If I then pan the map, the vector layer snaps to the correct zoom level.

Both tile packages were created in ArcGIS Pro using the same tiling scheme and zoom levels.

Is it possible to have a raster tile layer under a vector tile layer in the basemap in AGO?

0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

The issue is the ortho is a dynamic map service (map image layer) and not a tile layer/cached map service.

View solution in original post

0 Kudos
6 Replies
RussellRoberts1
Esri Frequent Contributor

Without adjusting the JSON you can create your basemap by using the Move the Basemap option and setting the layers as a reference or basemap layer and supports reordering. Checkout the doc here http://doc.arcgis.com/en/arcgis-online/create-maps/choose-basemap.htm#ESRI_SECTION1_5C28F0CDBF184E0D...

0 Kudos
Col_Forbin
New Contributor III

The "Set as reference layer" option is only available for the hillshade raster tile layer, which will place it above the vector layer in the basemap but I need it below.  And for both layers the Move up/Move down options are greyed out.

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Can you share your web map with me? and are you trying this on the web map you altered JSON on or a new one?

0 Kudos
Col_Forbin
New Contributor III

Shared.

I tried it on a new web map.

Thanks

0 Kudos
RussellRoberts1
Esri Frequent Contributor

The issue is the ortho is a dynamic map service (map image layer) and not a tile layer/cached map service.

0 Kudos
Col_Forbin
New Contributor III

Yes, that was it, thank you!