How do I display images in the pop up media for webmap i.e. separate images for each attribute in the feature class?

338
5
08-12-2019 04:36 PM
AndrewWelsh
New Contributor

Hi everyone,

I am hoping to display images in the pop up media for my feature class in the webmap I have created, with separate images for each attribute. So far I can display an image but it is the same one for all the features in the entire feature class e.g. I have 3 features in 3 different locations on my map - I want to show different images for each one, but I can only show the same one for all of them at the moment.

Would anybody know how I can get around this? 

Below is a screen shot of the configure attribute window - Is an attribute expression required to achieve what I'm after? 

Any assistance would be much appreciated!

Cheers

Andrew

0 Kudos
5 Replies
KenBuja
MVP Honored Contributor

You would need to have a field in the attribute table hold the image name you want attached to the feature. In one dataset, I have a field (Site_ID) that contains the image taken at a site. The name of the image has the Site_ID as its name. Here is how I have configured the image dialog for the popup

Also, please change this discussion to a question change discussion to question  

AndrewWelsh
New Contributor

Thanks for your response Ken. Do you mean your SITEID field in the attribute table holds just a text string of the image name or a path to the actual image? 

Cheers

AW

0 Kudos
KenBuja
MVP Honored Contributor

In this case, the Site_ID field contains just a string.

The images are stored in the directory as 2016_0.jpg, 2016_4.jpg,2016_6.jpg, etc. The rest of the path is built from the content in the URL portion of the configuration dialog in my previous post.

If you have the entire url of the image stored in the field, your configuration dialog would look like this

0 Kudos
DerekNewland
New Contributor II

Hello Ken,

I had the same question as Andrew and your answer solved my problem....mostly. If I click on my feature it will display the image I want but not in the correct "frame". I will show there are 2 images in the pop up but both are the image i want displayed, however, I'm also trying add links to each image to outside websites. So if I click on the second feature its appropriate image is displayed but if you click on the image it takes you to the first image's link. You need to know to click the arrow next to the image to go to was is essentially the same image in order to get to the appropriate link. I'm aware that may just be a limitation in the system and I may have to rethink how I'm going to do this. If you have an idea any help would be appreciated.

Thank you,

Derek

0 Kudos
colincampbell2
New Contributor

I have this same question too, but being a new student in GIS I do not understand exactly what you are doing with the Site_ID, and how that is able to make each pop up in an attribute table show their own separate photo images. Can I get a little more clarification, or connect by email please. Colin Campbell colcam3@gmail.com

0 Kudos