Hosted Feature Layer View Settings - Enable all data as read-only?

325
2
Jump to solution
10-19-2018 05:17 AM
FinnianO_Connor
Occasional Contributor II

I have a hosted feature layer that allows editors to only see and edit their own features.

Hosted Feature Layer Settings

Additionally I want to share all data to a different group of users. To do this I created a hosted feature view and did not enable editing.

Hosted Feature Layer View Settings

The result of this is that members of this group when they open the View are only seeing features they submitted and not all the data. If I want to let this group view all data I have to enable editing and allow them to see all data. The problem is that I have to allow some type of editing e.g. add feature, update feature etc.

It is possible for the hosted feature layer view to give read-only access to all the data without enabling editing?

Thanks,

Finnian

0 Kudos
1 Solution

Accepted Solutions
MikeMinami
Esri Notable Contributor

I believe you can do this. 

When you create a view layer, it inherits the settings of the source layer. In your case, editors can only see their own features. When you then disabled editing on the view, the editors can STILL only see their own features. This setting actually applies to viewers now because you've disabled editing.

To solve this, go to the view layer and enable editing on it. Then, change the property to Editors can see all features. Then, uncheck to disable editing. Now Save the settings.

Note: I tried this and looked at the configuration of the layer and it appears like it should work. I didn't actually test this with different users actually editing the layer.

Mike

View solution in original post

2 Replies
MikeMinami
Esri Notable Contributor

I believe you can do this. 

When you create a view layer, it inherits the settings of the source layer. In your case, editors can only see their own features. When you then disabled editing on the view, the editors can STILL only see their own features. This setting actually applies to viewers now because you've disabled editing.

To solve this, go to the view layer and enable editing on it. Then, change the property to Editors can see all features. Then, uncheck to disable editing. Now Save the settings.

Note: I tried this and looked at the configuration of the layer and it appears like it should work. I didn't actually test this with different users actually editing the layer.

Mike

View solution in original post

FinnianO_Connor
Occasional Contributor II

Mike, that worked - many thanks! Appreciate the description as to why it was happening too, makes sense.

Finnian

0 Kudos