Hosted Feature Layer String Field Indexing Fail

226
1
09-26-2019 09:54 AM
Sang_HyoukOum
New Contributor III

I am trying to set an index on string field and it fails with following error:

Column 'COUNTY' in table 'db_45156.user_45156.SWITRS_20190830_PRO_SWITRS_20190830' is of a type that is invalid for use as a key column in an index.
(Error Code: 400)

I have been using the same column for indexing years without an issue. Is this no longer supported? 

Tags (2)
0 Kudos
1 Reply
Peter_Klingman
Esri Regular Contributor

Hi Sang Hyouk Oum‌,

Setting a unique index on a text field is still supported - "you can set a unique constraint on any field type except system fields such as ObjectID, GlobalID, and FID." Are you setting the index in ArcGIS Online following this workflow: Add a unique constraint to a field—ArcGIS Online Help | ArcGIS

If you can send a zipped FGDB of your data to pklingman@esri.com I would be happy to publish a Hosted Feature Layer on my end and see if I run into the same error when creating the index. 

Hope this helps,

Peter

0 Kudos