Grouped Layers and Operations Dashboard

2132
18
07-23-2020 06:57 AM
LakshmiSankaran
Occasional Contributor

I am using the Group Layers function in the AGOL Map Viewer Beta. However, when I bring that map into the Operations Dashboard, the layers do not appear grouped, but just as two different layers to check on and off. This seems to defeat the purpose of grouped layers. Am I missing something?

Tags (1)
0 Kudos
18 Replies
CharlesHutchinson1
New Contributor II

Hi @JShi_EsriStaff ,

thanks for getting back to me. I think I’ve got my terminology a bit mixed up, when I refer to filters I mean category selectors in the header panel of a dashboard. The dashboards are set up with polygon features behind the category selector to zoom the map element to the polygon extent and filter map layers which share the same attribute. I've been updating the maps to the new format to be able to group layers in the table of contents.

The problem is that when a map in the classic format is saved in the new version and layers are added to a group these layers become unavailable for use in the category selectors in the dashboards. The grouped layers are visible in the map element and the layers widget has the grouped layer but when the selector > Actions > Filter is accessed the layers that have been grouped in the map display the message “The target element has a configuration issue.” If you remove them and try to add them back in to the list using Add target they are not visible under the map element in the list of targets.

This is reproduced if the new map viewer is used from the start, anything in a grouped layer is absent from the list when using Category Selector > Actions > Filter. The category selectors I am using are features but this behaviour is the same if Defined values or Grouped Values are used.

Thanks,

Charles 

0 Kudos
JShi_EsriStaff
Esri Contributor

Hello Charles, 

Sorry for my delayed response. Somehow I missed your reply posted earlier. Is this issue still reproducible with current version of ArcGIS Dashboards? If so, I highly suggest you to contact with Support and get your repro case logged. 

Thanks,

Julia 

0 Kudos
JShi_EsriStaff
Esri Contributor

Hi Charles, 

Thanks for sharing the details. I used a testing group layer but couldn't reproduce the issue as you described. Category selector worked fine with my testing group layer. I don't know if this issue is related with a particular group layer. Can you please either share your group layer here, or contact with Support to get a reproducible case? 

-Julia

0 Kudos
LakshmiSankaran
Occasional Contributor

If you could please add to the Grouped Layers issue - the grouped layers do not show in ArcGIS Online Assistant for its source to be changed etc.

Lakshmi

0 Kudos
JShi_EsriStaff
Esri Contributor

Hi, 

The behavior you shared should not be expected.. If the group layers are displayed well in the new Map Viewer, they shall be able to view the same way in new Dashboards. If you'd like to share this group layers in a private group with my username (jshi_CloudyGIS), I can take a quick look. 

Julia

0 Kudos
AdaLi1
by
New Contributor III

Hi @JShi_EsriStaff,

Any layers in a web map viewer layer group is not selectable for any ArcGIS Dashboards widget actions - be it filters, map actions, or normal widget actions. I had configured an action before the layer was in a group. After I put it in the group in the web map and went back to the dashboard, the layer disappeared from the action list and what remains is the web map icon and it says 'The target element has a configuration issue'.

Please advise!

Thanks

0 Kudos
JShi_EsriStaff
Esri Contributor

Hi, 

I would suggest to talk with Esri Support and get an issue logged since this behavior can either incorrect or by design.  

Thanks!

0 Kudos
JimmyWalth
New Contributor II

I am having the exact same issue with recently created grouped Layers in a web map used on my Dashboard.  No actions allowed.

0 Kudos
AdaLi1
by
New Contributor III

Fantastic news! As of today, Dashboards has been updated and the bug I logged has been fixed:

BUG-000141186 - In ArcGIS Dashboards, the map's Layer actions option does not recognize group layers, and making selections is not possible.

 

0 Kudos