Group layers in Map Viewer cause to return ungroup the next day.

615
4
04-11-2022 08:02 AM
PROBERT68
Frequent Contributor

Last week, I use a Map Viewer and had lots of layers that I group together. I mean it is a lot of work I put up to this work  and then I need to add a layer  from my AGOL content and then the next day I notice that the group I had had ungroup and I had to re- do all the work all over again.

Has anyone had that experience ?  

I read this Organize Layers from ArcGIS Online Get Started and did not mention anything...

Organize layers (Map Viewer)—ArcGIS Online Help | Documentation

I just want to post this to ensure it doesn't happened again. I cannot recall what it had happened because there were lots of things to process that day.

 

Tags (3)
0 Kudos
4 Replies
RussRoberts
Esri Notable Contributor

Group Layers are only saved in the web map and not at the layer level at this time. 

0 Kudos
PROBERT68
Frequent Contributor

Can you explain me what is layer level means ? 

0 Kudos
RussRoberts
Esri Notable Contributor

Sure. 

The layer level like a layer item - Feature Layer item that's created when you publish a hosted feature layer to ArcGIS Online. So their is currently now way to push the group layers you generate back to the feature layer item. Also at the service level feature services do not support group layers. So once you set your group layers in a web map you have to save the web map and they will be preserved in that map and supported by apps that support group layers. If you open this map in a classic viewer like Map Viewer Classic, Dashboard Classic or Web AppBuilder the group layers will show up as a flat list bc they are not supported.  

0 Kudos
PROBERT68
Frequent Contributor

Ok . It is sort of over my head but do you have a picture of  what you are describing to help me visualize what you are talking about ? Thanks

0 Kudos