Extruded lines do not appear in web scene

182
4
Jump to solution
06-15-2020 07:07 AM
RandyMcGregor1
New Contributor III

I have created a scene in ArcGIS Pro with a series of points that I created for testing. I extruded them down 1500 feet and ran layer 3d to feature class to get the following effect:

When I share t his as a scene to my arcgis account, I cannot see the lines. I see the surface and the points, but the shafts simply aren't there.

I see the lines in the legend, they are not visible in the scene (also, number 5 disappeared for some reason).

Hoping I'm just missing something simple that someone could set me straight on? Sorry if it's an obvious thing I'm overlooking. I'm just getting started in 3D.

Thank you,

Randy McGregor

0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

This is a known limitation of the geometry not being OGC compliant.

Problem: Vertical lines are not drawn in ArcGIS Online Scene Viewer 

If you use this tool with the OGC standard you will see you will get errors on those veritcal lines.

Check Geometry—Data Management toolbox | Documentation 

View solution in original post

4 Replies
RussellRoberts1
Esri Frequent Contributor

This is a known limitation of the geometry not being OGC compliant.

Problem: Vertical lines are not drawn in ArcGIS Online Scene Viewer 

If you use this tool with the OGC standard you will see you will get errors on those veritcal lines.

Check Geometry—Data Management toolbox | Documentation 

View solution in original post

RandyMcGregor1
New Contributor III

Thank you!

Is there a workaround? The "workaround" offered seems to just be an explanation of why this doesn't work:

Solution or Workaround

The data store used by ArcGIS Online requires geometry to be OGC-compliant. However, Portal for ArcGIS uses the internal Esri shape format which does not necessarily need to be OGC-compliant. Straight-up vertical lines are not treated as invalid geometry when published to Portal.

0 Kudos
RandyMcGregor1
New Contributor III

I see. The solution is to use Portal, rather than ArcGIS Online. That is not an option. I think I saw someone recommend buffering the points and creating cylinders. I'll try that...

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Yup converting the lines/tubes to multipatch and publishing a 3D Object scene layer can work around the issue you are having above.