Error loading tile package to ArcGIS Online "Exception while transferring multipart item..."

674
5
Jump to solution
03-26-2019 06:52 AM
AmyRoust
Occasional Contributor III

I have been trying to load a very large tile package to our ArcGIS Online Account. Per this page, we meet the requirements for loading it. However, I have tried twice now and received this error message:

Screenshot of error message "Exception while transferring multipart item to object store..."

I'm not sure what makes the tile package a multipart item. I tiled imagery at multiple scales in JPG format, so perhaps the "multipart" refers to the different scale levels?

I have successfully loaded large TPKs to our ArcGIS Online account before. This is the first one I have created in Pro, however (ver 2.3.1).

0 Kudos
1 Solution

Accepted Solutions
KellyGerrow
Esri Frequent Contributor

Hi Amy,

Can you get in contact with tech support? Did you upload this through My content? Are you able to share the tpk?

To explain the error message:

Multipart is the method that is used to upload large datasets in small chunks. This enables larger files to be uploaded faster. 

Either way, this shouldn't be happening so it will help to have an analyst dig into the specifics with you.

Thanks,

Kelly

View solution in original post

5 Replies
KellyGerrow
Esri Frequent Contributor

Hi Amy,

Can you get in contact with tech support? Did you upload this through My content? Are you able to share the tpk?

To explain the error message:

Multipart is the method that is used to upload large datasets in small chunks. This enables larger files to be uploaded faster. 

Either way, this shouldn't be happening so it will help to have an analyst dig into the specifics with you.

Thanks,

Kelly

AmyRoust
Occasional Contributor III

Thank you for explaining what the error message meant, Kelly! That was a big help.

I ended up publishing the tile package using ArcGIS Pro. It took about 12 hours to complete, but it successfully loaded into AGOL. So, I won't be making a call to tech support, but that was my next move if Pro hadn't come through for the win.

0 Kudos
RussellRoberts1
Esri Frequent Contributor

We found the issue that caused the large file to fail to upload and throw that error. This issue has been fixed and you can now upload your really large files and not see that error through My Content - Add Item.

OraleeNudson
New Contributor

Hi Russell, we are seeing this multipart upload problem with ArcGIS 10.8.1 + PFA ES2 Patch.  Is it possible the issue has been reintroduced in this newer version of ArcGIS?  What can we do on the user end to resolve the issue?  Thank you.

0 Kudos
SPisOs
by
New Contributor

Hi Russel, I also just got hit by the error

Exception while transferring multipart item to object store: Exception. Unable to add part to Multipart item key <key-here>

I was adding an Item (Tile Package) to AGOL using arcgis module 1.8.1.  I called

gis.content.add()

The multipart upload initially worked OK, but it crashed after a while with the above error.

The operation seems to work in most attempts, but in some cases it fails. 

Is there a limit on the key length? if this is a concatenation of <itemguid>/<FileName> part_number then should I use shorter file name?

But on the other hand it worked for keys of theoretically identical lengths/the part just before the crash.

or is there a limit on total number of Parts that can be uploaded please ?

0 Kudos