Enabling Sync or Keep track of created and updated features prevents hosted feature layer save

469
1
01-18-2021 02:03 PM
BillHeigh
New Contributor III

Hi guys and gals,

I am attempting to publish an editable app in Field Maps and am having trouble. Currently the main issue is that as soon as I check the Enable Sync checkbox, the layer fails to save. I get this in the upper right-hand corner:

BillHeigh_0-1611007232619.png

And I have tried and tried but to no avail. As soon as I uncheck which ever one prevented me from saving, I can save (other settings) again. I have tried rebuilding indices and creating a new web map from the hosted Feature Layer, no joy.

Help!  = )  Thanks, Bill~

 

0 Kudos
1 Reply
BillHeigh
New Contributor III

I think I solved my own issue. I have been migrating my inspection app efforts this month and I started with Collector in 2017. With each iteration, there have been changes and improvements and this effort was no different.

I had several schema changes since publishing to AGOL, and eventually I think you reach a point in the AGOL environment where there have been too many changes to continue updating layers designed for editing and you have to start over.

And that's what I did. I downloaded everything worth keeping from AGOL and deleted everything on AGOL having to do with that app and/or fixing that app. I started over with Desktop (I have been trying Pro the last few months, but it's a learning curve). I created the FGDB I wanted, and started a new MXD and published my inspection map again. Everything started working as expected again.

Cheers, Bill~

 

0 Kudos