Domain Editing Option No Longer Available.

586
9
Jump to solution
07-01-2020 12:30 PM
Jefcoat_Nathan
New Contributor III

As of this morning the option to edit the domain in one of my feature services has been removed along with the same option for its related table.  I noticed there has been an update to Arc Online. Is this just an oversight with the new update?  I was able to use this functionality yesterday.

Thanks

- Nate Jefcoat

0 Kudos
1 Solution

Accepted Solutions
Jefcoat_Nathan
New Contributor III

Well having the joined feature was the issue.  Thanks for helping me out!

View solution in original post

9 Replies
Peter_Klingman
Esri Regular Contributor

Hi Jefcoat, Nathan‌, 

I just looked at one of my hosted feature layers and was able to add a domain (test_new). I also edited some existing ones. 

Are you able to provide some screenshots or an error you're seeing? For all issues that appear to be release-related we recommend getting in contact with Esri Support. Let me know, and I can get a case started for you - a dedicated analyst will be able to look at the hosted feature layer, and if it was an issue related to release, get it to our development team ASAP. 

Please let me know here or email pklingman@esri.com with any other questions. 

Thanks,

-Peter 

0 Kudos
Jefcoat_Nathan
New Contributor III

Hi Peter,

Here is a screen shot:

The option to edit is no longer available. I added many of the values on the list yesterday.  Any help would be appreciated! 

0 Kudos
Peter_Klingman
Esri Regular Contributor

Thanks for the screen shot on this - how many total domains do you have? 

I would try downloading the service as a FGDB and republishing a new, test, hosted feature layer to see if the domains become editable. Outside of this, since the issue seems service-specific I think it might be best to get a support case started. 

Hope this helps,

-Peter 

0 Kudos
Jefcoat_Nathan
New Contributor III

There are 206 domains currently.  Yes, it must be service specific as I can edit and create lists on other services.  Is there a limit to the amount of domains a service can hold?

Thanks

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi Nathan,

No, there is no limit, just wanted to gather some more information as to why only this service might be exhibiting the issue after the update. Is it every field in the service or only one field? Is there a chance the you created a hosted feature layer view off of the layer and are looking at that?

If you compare the JSON at the admin endpoint of a service where you can edit/add domains vs. the problematic service, does anything differ related to the schema or domains? 

Admin endpoint for feature layers: https://services.arcgis.com/<OrgID>/arcgis/rest/admin/services/<serviceName>/FeatureServer, then select Update Definition. 

If you are able to share the layer with PeterK_Ess or link it here if it is public, I would be happy to look at it as well. 

Thanks,

-Peter

0 Kudos
Jefcoat_Nathan
New Contributor III

Hi Peter,

It is occurring on all fields containing domains for this service.  There are multiple view layers that this is the source of but I've double checked (and the names are different) to make sure that wasn't the case.  I did create a join layer from it, could this be the issue? I checked the JSON and nothing looked off.  I will send you a link if you have time to look at it.

Thanks

-Nate   

0 Kudos
Jefcoat_Nathan
New Contributor III

Ahh, sorry the link is not public and only accessed through my organization.

0 Kudos
Jefcoat_Nathan
New Contributor III

Well having the joined feature was the issue.  Thanks for helping me out!

View solution in original post

Peter_Klingman
Esri Regular Contributor

Glad it is resolved, Nathan, happy to help out! Yeah, a Join with the output as a view will prevent altering domain values. 

0 Kudos