District Lookup Widget Search Bar Issues

895
17
05-09-2019 09:37 AM
deleted-user-1_r2dgYuILKY
Occasional Contributor III

When I add more than one search source to the district lookup widget, I can't type more than a couple of characters into the search bar before the dropdown arrow highlights. Even if I choose one of the search options, this behavior continues. I can't type in a full place name or address. This does not happen with the standard search bar widget. Anybody else having this issue? 

0 Kudos
17 Replies
deleted-user-1_r2dgYuILKY
Occasional Contributor III

OK. I switched to a better city geocoder that doesn't have suggestion capability. Any time frame on when the multiple search sources bug will be fixed? I need to be able to add our facilities as a search option, but I can't until that's fixed.

0 Kudos
MichaelVolz
Esteemed Contributor

Are you concerned with suggestions not working properly?  Depending upon the version of ArcGIS Server you are using, you may be encountering a bug.  You can try a keyword search through GeoNet and you should get some hits related to this: geocode, suggestions, bug.

0 Kudos
deleted-user-1_r2dgYuILKY
Occasional Contributor III

Well, we're stuck on Server 10.3, so that could be the problem. I far more concerned about not being able to have more than one search source in the district lookup widget than being able to have suggestions in the search. We need people to be able to search for their address AND for the names of schools.

AzizaParveen1
Esri Contributor

Levi, 

Multiple search source works fine in District Look Up as you can see in the screenshot I have posted. you can set up multiple feature layers as search source like this screenshot below. Only bug here is zoom scale for individual feature layer is not being honored.


Now if you must use your own geocoder as search source, make sure that geocoder is working as expected, If you search an address/location using your geocoder does it return any value? If not, then your geocoder in not working and it is hard to say why without troubleshooting. In this case I would suggest that you reach out to ESRI Support for help.

0 Kudos
deleted-user-1_r2dgYuILKY
Occasional Contributor III

So the typing bug was fixed? It's not that I can't add multiple search sources, it's that the search bar doesn't function when I do. You said this was a known bug. This happens whether I use one of our geocoders, or city or other local government geocoders, in addition to hosted layers. I also don't want users to have to choose which search source to use. It's tedious and unnecessary. 

0 Kudos
AzizaParveen1
Esri Contributor

I apologize if I confuse you, you have mentioned few issues in your post, 

1) Search text box is losing focus,

This is a known bug logged into our system, optimistic about it to get fixed in future release.

Even though the search box is losing focus, you should still be able to complete your typing and your search, only annoying issue here for you to bring focus to the search box over and over, this is what we are going to fix.

2) When you type in an address, it does not zoom to this point, even though I've set the zoom level in the search settings. 

This is also an known issue, I am not sure about the time frame of fixing this issue.

3) I'm using a geocoder and one of our hosted featured services in the search. Is there a way to make it so that users don't have to choose which search source to use? I would like it to automatically search both. User's can either type in their address or the name of a facility.

This is working fine in District Look Up, it should automatically search both of your search sources, I would suggest to check your geocoder outside of this widget (In REST endnpoint or ArcGIS desktop) to make sure it is working as expected, if not please reach out to ESRI Support, they will be able to help you fix this issue. 

Please let me know if I missed anything. Thanks.

 

0 Kudos
deleted-user-1_r2dgYuILKY
Occasional Contributor III

OK, that's pretty clear. I just tested it with two sources and it does search both. I noticed that if I type in the name of a facility, it allows me to type the whole name and search. If I start typing in address numbers, the search bar loses focus. 

AzizaParveen1
Esri Contributor

We fixed the search text box losing focus issue in ArcGIS Online 7.2 release (June 2019).

0 Kudos