Crowdsource polling app, I'm getting a popup error window.

1560
8
Jump to solution
11-08-2016 09:56 AM
KimSapunar
New Contributor II

I am using the Crowdsource polling app.  When a user goes to add a comment, a popup window with "[OBJECTID] A required field is neither initialized nor in the form" comes up.  The window can be closed, and the comment gets added, and votes are registered, but what is triggering the error message?  I'm using a hosted geodatabase with a related empty table to receive the comments from the crowdsource polling app, editing is enabled.  Any suggestions?

0 Kudos
1 Solution

Accepted Solutions
AllisonMuise1
Regular Contributor

Kim Sapunar‌ - Glad you got it working!

Sorry I should have been clearer. I could see that when the data was downloaded the field type was Object ID, but at the REST endpoint, the field type was EsriFieldTypeInteger instead of esriFieldTypeOID

This must be related to publishing by sharing a GDB vs from Desktop. Both publication methods should result in the same field types, so I'll investigate this further with the AGOL team.

View solution in original post

8 Replies
AllisonMuise1
Regular Contributor

ksapunar‌ Can you share the URL to your app? The service, map, and app will all need to be shared with Everyone.

KimSapunar
New Contributor II

Here’s my url, all layers, the service and the app are shared with Everyone. A comment and a vote is recorded, but still getting the popup error box.

http://mwvcog.maps.arcgis.com/apps/CrowdsourcePolling/index.html?appid=e64ec6754e3d43038667c5151244890a

0 Kudos
AllisonMuise1
Regular Contributor

ksapunar‌ It appears that the OBJECTID field for the table is an integer field rather than an OID field and the app isn't handling it very well. I'm not sure how OBJECTID was created as an integer field, but perhaps re-create the table and publish it again?

We'll also add a check to the app to help it handle non-OID id fields.

0 Kudos
KimSapunar
New Contributor II

The Comment table and the Feature class layer in my geodatabase both have Object IDs – both are Data Types of Object ID (I’m looking at the properties currently) they are not an integer field. The relationship class is not based on the Object ID, it’s based on the Global ID (feature class) and CommID field as a GUID in the comment table.

I have already recreated the geodatabase and loaded it up again, and still receive the error message. I am uploading the data by a zipped geodatabase file into my content.

Any other suggestions?

0 Kudos
KimSapunar
New Contributor II

I solved this by uploading my geodatabase via ArcMap (Share as a service), rather than uploading a zipped geodatabase file.

AllisonMuise1
Regular Contributor

Kim Sapunar‌ - Glad you got it working!

Sorry I should have been clearer. I could see that when the data was downloaded the field type was Object ID, but at the REST endpoint, the field type was EsriFieldTypeInteger instead of esriFieldTypeOID

This must be related to publishing by sharing a GDB vs from Desktop. Both publication methods should result in the same field types, so I'll investigate this further with the AGOL team.

View solution in original post

ShariForbes
New Contributor III

Hello! I am having the same issue with the errors with my Crowdsource Polling app related to the tracking fields-->

" [Last Edited Date] A Required field is neither initialized nor in the form"

Everything is working, comments can be added, the related table is updating and editor tracking is enabled and working. 

Here is the URL: 

http://planogis.maps.arcgis.com/apps/CrowdsourcePolling/index.html?appid=162c8836dbc64610bf4e61980d9... 

0 Kudos
AllisonMuise1
Regular Contributor

Hi Shari,

I saw the message you are referring to when I peeked at your app on Friday, but when I went to take a closer look this morning it seemed to be working fine. How did you resolve this?

Allison

0 Kudos