Build attribute table fails when projecting ESRI 10 m land cover raster

549
6
Jump to solution
07-27-2021 07:01 AM
agrade132
New Contributor II

Hello all. I recently downloaded a tile from the new 2020 ESRI 10 m land cover data (as a tif), and I notice that when I go to "project" the raster to an Albers Equal area projection, I lose the attribute table with the categorical land cover variables. Once I go to "build attribute table," it fails with an error 000049. Build attribute table will work with the original tif file. I checked and when I project the raster, the bit, band, and unsigned don't change. How do I fix this issue?

 

Thank you, Aaron.

0 Kudos
1 Solution

Accepted Solutions
DanPatterson
MVP Esteemed Contributor

make sure you save it as a *.tif .  Save it to your project folder. See what the raster type is then.


... sort of retired...

View solution in original post

6 Replies
DanPatterson
MVP Esteemed Contributor

If you are using the 

Project Raster (Data Management)—ArcGIS Pro | Documentation

Did you make sure that you used the Nearest option to maintain the categorical values?


... sort of retired...
agrade132
New Contributor II

Thank you for replying Dan. Yes, I did do that, and I just reran to double check and it still failed with the same error.

0 Kudos
DanPatterson
MVP Esteemed Contributor

What is the input and output raster information then?  

Build Raster Attribute Table (Data Management)—ArcGIS Pro | Documentation

The exclusion as listed in the help is

You cannot build a raster attribute table for a raster dataset that is a pixel type of 32-bit floating point.

Which shouldn't be the case for categorical data.


... sort of retired...
agrade132
New Contributor II

The input raster is: TIFF, single band, 10,10 cell size, unsigned integer 8 bit. WGS_1984_UTM_Zone_12_N, Meter, Degree.

I then used Data management --> Projections and Transformations --> Raster --> Project Raster. Used NEAREST as the sampling technique, selected WGS_1984_Albers for Output coordinate system (no geographic transformation).

The output raster from that process was in GRID format, unsigned integer, 4-bit, 1 band.

Could it be that it converts to 4-bit that's the problem?

0 Kudos
DanPatterson
MVP Esteemed Contributor

make sure you save it as a *.tif .  Save it to your project folder. See what the raster type is then.


... sort of retired...
agrade132
New Contributor II

Yes, that did the trick! When I saved it as a *.tif I'm able to see the attribute table without having to build one.

 

Thank you!

0 Kudos