Bug? AGOL application editor hangs

824
3
10-31-2016 11:38 AM
TomRippetoe
Occasional Contributor

Hello.

I have built an Application in my AGOL Organization account.  When i click on 'Edit Application', a new web page is loaded (Web AppBuilder for ArcGIS), but in the location where i expect my application to be there is only a spinner. And it spins without end.

I can still access the application, as can other users in my organization. But i cannot edit it.

Any ideas on what's going on?

Thank you.

0 Kudos
3 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Tom,

I would try different browsers (i.e. Chrome, Firefox, IE) to see if the behavior is the same.  Also, you can click F12 on your keyboard and this will bring up your debug console.  This should report errors under the 'Console' tab.

TomRippetoe
Occasional Contributor

Hi Jake.

Thanks for the suggestions.  In my original post, I was using Chrome.  So, I tried IE 11 and was able to launch the web app builder as expected.  

I went back to chrome and re-tried.  I got the same bad behavior as before so I popped open the Chrome debugger.  In there, i saw an error message like this:  

Blocked a frame with origin "http://...." from accessing a cross-origin frame.

I am not sure why, but i decided to manually enter the URL for the web app builder specifying 'https'.  In Chrome and IE 11, specifying https in the URL for the web app builder worked fine.  Unfortunately though, AGOL is defaulting to using HTTP when launching 'Edit Application' from My Content browser, even when i start the AGOL login process with 'https'.   

Any idea how i can set the default protocol to https?  or why the problems with Chrome and http?

Thanks again for your help.

0 Kudos
KatieCullen
Regular Contributor II

Starting with Google Chrome version 50 and potentially other browsers, some HTML5 web APIs will require using a secure origin like HTTPS to work correctly.

 

This blog explains this in further detail: Increased web API security in Google Chrome | ArcGIS Blog 

You can consider enabling the "Allow access to the organization through HTTPS only" security setting to ensure that your organization's data as well as any temporary identification tokens that allow access to your data are encrypted during communications over the Internet.