ArcGIS Server JSON Queries not working in new mapviewer

130
0
10-27-2021 03:17 PM
Labels (3)
StefanieWenker
Occasional Contributor

I created a map in the classic mapviewer that references secured ArcGIS Server layers (credentials are not stored). One of the layers I was using is a spatial view in the SDE and another has related tables through a relationship class.

When I open the map in the new mapviewer the data in the layers isn't showing on the map (although I am able to open the attribute table and look at the data). When I look at the console I get the error "An SQL statement with comments and/or semicolon is invalid".

I have tried to remake my map so that I can use it in the new ArcGIS Dashboards and the data shows up when it is just looking for the objectid, but as soon as I try to symbolize the data on a field I get the same error, or sometimes - an invalid SQL statement was used.

I checked my ArcGIS server logs and it is pretty much the same error: An invalid where clause or definition expression has been requested: followed by my fieldnames.

How did the way that the JSON query is made change in the new mapviewer, and how can I work around this issue?

 

0 Kudos
0 Replies