ArcGIS Online-Portal: popup bug fields bug?

603
3
08-12-2020 06:43 AM
KevinMacLeod4
Frequent Contributor

I have a Portal 10.8 webmap. Published from the latest Pro from data in MSSQL SDE. It has one layer with popups configured. They work fine in the Webmap viewer:

https://portal.axisgis.com/portal/home/webmap/viewer.html?webmap=59641cba9f7d4fc39a21d3125b48e9a5&ex...


Oddly when I added the service  FranklinMA/Parcel_Popup (MapServer)  as a map image layer, enabled popups, nothing at all showed up, it said No Information Available. So then I added the sublayer as a FeatureLayer (i.e with the /0 at end)  and it shows the popup fine in the webmap viewer.  (never seen this happen before, but this is my first time using Portal so I am thinking it's definitely a design issue or bug with Portal. The layers are public)  Also I noticed duplicate labels for the Lot numbers in the Pen example below, but not in the webmap. (in the Pen they are duplicated. But labels are NOT on. It is not respecting that webmap setting; another thing I've never seen before)

However, only one field renders in the popup in even the basic Popup API Sample. https://codepen.io/kevinsagis/details/BaKodWZ 

All other fields are blank. Very weird. The fields are from a joined table but that is fine; they load fine even in the Webmap viewer in a new incognito tab when logged out. Same with the image that is linked. Works fine in the webmap But in the sample they don't load. (which is because the images are coming from a filename URL field)

Actually now the image is not even loading in the sublayer FeatureLayer. Same 'sql error' as below. Anyone else seeing this?

In the Network traffic it shows an error:

  1. {error: {code: 400, extendedCode: -2147220949, message: "Unable to complete operation.",…}}
    1. error: {code: 400, extendedCode: -2147220949, message: "Unable to complete operation.",…}
      1. code: 400
      2. details: ["An SQL statement with comments and/or semicolon is invalid."]
        1. 0: "An SQL statement with comments and/or semicolon is invalid."
      3. extendedCode: -2147220949
      4. message: "Unable to complete operation."

https://codepen.io/kevinsagis/details/BaKodWZ 

Complete code:   

<html>
 <head>
 <meta charset="utf-8" />
 <meta
 name="viewport"
 content="initial-scale=1,maximum-scale=1,user-scalable=no"
 />


 <title>Load a basic WebMap | Sample | ArcGIS API for JavaScript 4.16</title>
<style>
 html,
 body,
 #viewDiv {
 padding: 0;
 margin: 0;
 height: 100%;
 width: 100%;
 }
 </style>
<link
 rel="stylesheet"
 href="https://js.arcgis.com/4.17/esri/themes/light/main.css"
 />
<script src="https://js.arcgis.com/4.17/"></script>
<script>
 require([
 "esri/views/MapView",
 "esri/WebMap",
 "esri/config",
 "esri/widgets/Popup"
 ], function (MapView, WebMap, esriConfig, Popup) {
 

esriConfig.portalUrl = "https://portal.axisgis.com/portal";
var webmap = new WebMap({
 portalItem: {
 id: "59641cba9f7d4fc39a21d3125b48e9a5" }
 });

 var view = new MapView({
 map: webmap,
 container: "viewDiv"
 });
 });
 </script>
 </head>
<body>
 <div id="viewDiv"></div>
 </body>
</html>‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍
0 Kudos
3 Replies
KevinMacLeod3
MVP

I tried on the ArcGIS Online Organization, same issue. The Parcel-Poly layer which has Joined tables (in Pro) does not show results from a mapImage layer popup from a /MapServer endpoint. Only from featureLayer but even then, image doesn't work in the webmap popup and no attributes work in the popup in the JSAPI of any version; and worse, Labels turn on for the featureLayer in the JSAPI. But they shouldn't; they're off in the webmap (they stay off there, but do not obey webmap json and turn on again in the API)   Seems to be a bug with Joined tables and Popups. I'm working with Support on it now.

https://caitech.maps.arcgis.com/home/webmap/viewer.html?webmap=088d168d8322454fa67d0fbb68c3d075 

0 Kudos
KevinMacLeod4
Frequent Contributor

It affects AGOL webmap as well. Simply having a joined table to a file geodatabase layer it does not show popups. When added as MapImager layer.  It says "No Information Available" with the Code 400 network traffic error. 

http://www.arcgis.com/home/webmap/viewer.html?webmap=2fec4f329b734d5a857209b3e8c33fa3 

As featureLayer it shows popup info for the fields in the webmap but does NOT show in the API like in Code Pen. So in both ways of adding the layer popups simply don't work with a joined table. The attributes show up fine if I force them with a permanent join but I need the join to be in real time since the data tables (which are in MS SQL server) get updated periodically.

https://codepen.io/kevinsagis/pen/BaKodWZ 

0 Kudos
KevinMacLeod3
MVP

found the cause... Problem: Pop-ups do not display information in ArcGIS Online when feature layers in the map service ... 

The % character in the field name. 

But..None of these workarounds work. FeatureLayer: does not work. (works in webmap but that is not useful itself; as it does not work once in the JSAPI so doesn't work in viewers; I tried 4.9 through 4.17)   Adding data by Add Data button: Doesn't work. Still adds % sign. So until this is fixed - a joined table to date in file gdb doesn't work in a popup in ArcGIS Online or web viewer APIs, which probably affects many users.  It looks like this was reported first at 10.1.  

Update ---  I updated to 10.8.1 in hopes it was fixed. It's worse. I found that the layer simply disappears, if there is a join. Instead of no working attribute fields the layer altogether vanishes from the REST service listing. I was publishing from the latest Pro 2.6. I then removed the join and republished and the polygon layer appears fine. Then re-join to the two SQL Server tables and republish, and polygon layer in the fgdb disappears again. I've shown Support and they are researching.

0 Kudos