ArcGIS Online Log In not working

155
1
12-09-2021 09:17 AM
TaylorMathis
New Contributor

I got an invitation to join an ArcGIS Online Organization which I was expecting as part of my job. I followed the link to establish my password. I entered in the password and it seemed like it worked and then it took me to the log on page and I entered my user name and password and it said in valid username or password. So I thought maybe it didn't take my new password so I tried setting the password again and got an invalid security response for resetting password. I have tried signing in on chrome, firefox, and edge and clearing the cache none of that worked. I have set up accounts with other ArcGIS Online Organizations before with no issues.  Does it take time for the account to become active? Should I try hitting the forgot password button?

0 Kudos
1 Reply
HollyTorpey_LSA
Occasional Contributor

In my experience, you should be able to log in with a new account right away.

Sometimes this happens when AGO is trying to log you into another organization with that username and password. Do you see this link beneath the username and password boxes? 

HollyTorpey_LSA_0-1639073624753.png

If so, click the link that says "Sign in to your account on ArcGIS Online" and try again. Other times you might see this beneath the username and password boxes:

HollyTorpey_LSA_1-1639073733243.png

In this case, you can click the dropdown arrow and select the organization you are trying to log into before submitting your username and password. 

Hope it's something easy like this!

Holly

- Holly
0 Kudos