Select to view content in your preferred language

All numbers showing up with 2 decimal points.

424
1
12-23-2022 11:59 AM
Larane
by
New Contributor

I have an issue that seems like it would be super simple to fix but I've just been stuck on this simple task so I'm hoping someone can help me out. I have a map that is shared through the classic map viewer onto our website and in the popup I can't get the year to just show up as a year- 2022. No matter what I've tried it keeps showing up as 2,022.00 this goes for other actual numbers fields as well. I would like to have the year just read as a text field so it doesn't edit it at all and the other fields I'd like to just have a whole number without the decimal points. These are in hosted feature layers, I've tried editing the source content and the layer on Arcgis online. What am I doing wrong? 

0 Kudos
1 Reply
BernSzukalski
Esri Frequent Contributor

Unless I am misunderstanding things completely (always a possibility!) this should be easy to do.

In Map Viewer Classic you should be able to set the decimal places and use of the 1000 separator after you add the hosted feature layer to your map. In the Content tab, open More Options (...) for the layer that has the field in question. Choose Configure Pop-ups, then Configure Attributes

BernSzukalski_0-1672160439557.png

Then make the appropriate adjustments, and save your map.

BernSzukalski_1-1672160472866.png

If you own the layer, you can also write those setting back to the feature layer using Save Layer

BernSzukalski_2-1672160528732.png

 

0 Kudos