Select to view content in your preferred language

AGOL web map not showing symbols correctly but previously were

559
3
05-05-2023 11:04 AM
ShannonLunderville
New Contributor II

I have a web map created in ArcGIS Online, it WAS working fine. When I need to push new data up to it I do it via Pro (I'm at 3.1.1) and choose Overwrite Web Layer. Today when I pushed up my data and went to check the map (via the URL) the symbology has been completely downgraded. I've read others posts and have made sure to choose "use symbol types compatible with all clients". That didn't help. If I open the layer in AGOL it shows up fine, if I open it in Pro from AGOL, it shows up fine. If I open it in Classic Viewer, downgraded symbols. And if I open the URL of the web map, I get the downgraded symbols. I really don't want to have to blow away the layer in my map and re-customize everything. Does anyone have any insight on what is going wrong or what I missed?

0 Kudos
3 Replies
RussRoberts
Esri Notable Contributor

I would post this in ArcGIS Pro community but my comments would be to make sure the overwrite had the configuration to use symbol types compatible with all clients checked. Map Viewer will not upgrade an existing symbol from classic/basic to a vector version.

Follow up question: Why are you using Map Viewer Classic vs. Map Viewer.

 

Thanks! 

0 Kudos
ShannonLunderville
New Contributor II

Based on the similar posts I saw, I did choose the option to be "compatible with all ...", that didn't help.
Technically I was using Map Viewer, I just happened to go to Classic Viewer to possibly edit the symbology and that's how I noticed the symbols were downgraded in Classic. I don't really ever change the map, just the data so I admittedly stumble around a bit when I do need to change something in the map and thus the "visit" to Classic viewer.

0 Kudos
RussRoberts
Esri Notable Contributor

Thanks! Would recommend bringing that up with the Pro community just incase there is a step or workflow where the vector symbols are coming through when you expect the non-vector version to be used and have simple picture markers used. Also thanks for the feedback on MVC vs. MV. We like to track to see if there is a missing workflow or issue that MV is missing and MVC has.

0 Kudos