AGOL hosted feature layer geometry missing after linking Survey123 form, displays in ArcGIS Pro but not in web map

217
3
Jump to solution
08-04-2022 12:15 PM
LinzMess
New Contributor II

I created a feature layer in ArcGIS Pro and then published it as a web layer to AGOL. After publishing, I created a web map with the feature layer, configured pop-ups, etc. and embedded the web map into a Hub site. Everything was working as expected until I linked to the existing feature layer through Survey123 (created and published a survey via Survey123 Connect with the intent of allowing users to add data to the feature layer via survey embedded in a dashboard). The survey published without warnings, but now the feature layer geometry (points) are not visible in the web map. Additionally, the feature layer shows nothing when navigating to the item in AGOL and clicking the visualization tab. However, when I open the feature layer in ArcGIS Pro, the points display as expected.

When I use the survey to add new features, they appear in the data table but do not display within AGOL on the web map or visualization tab in the item details. However, they do display when I open the feature layer in ArcGIS Pro. I did remove the feature layer from my web map, save, then re-add. This did not solve the issue.

LinzMess_0-1659639904253.png

 

0 Kudos
1 Solution

Accepted Solutions
MCameron
Esri Contributor

Hi @LinzMess 

I hope you are well. I believe I have seen this issue before, but in order to confirm if it is the same behaviour, could I please ask you to check the following: 

  • Open the item details page for the fieldworker feature layer view (or the feature layer if you have created it with Survey123 Connect),
  • Open the settings tab and Navigate to the section "What features can editors see"
  • Could you confirm if the current option checked is "Editors can't see any features even those they add". 
  • If so, please change this setting to either "Editors can see all features" or "Editors can only see their own features".
  • Click Save to save the changes. 

Please do share with me if after making this change, you can now see the data within the web map as expected. 🙂

View solution in original post

0 Kudos
3 Replies
MCameron
Esri Contributor

Hi @LinzMess 

I hope you are well. I believe I have seen this issue before, but in order to confirm if it is the same behaviour, could I please ask you to check the following: 

  • Open the item details page for the fieldworker feature layer view (or the feature layer if you have created it with Survey123 Connect),
  • Open the settings tab and Navigate to the section "What features can editors see"
  • Could you confirm if the current option checked is "Editors can't see any features even those they add". 
  • If so, please change this setting to either "Editors can see all features" or "Editors can only see their own features".
  • Click Save to save the changes. 

Please do share with me if after making this change, you can now see the data within the web map as expected. 🙂

0 Kudos
LinzMess
New Contributor II

@MCameron Thank you, that was indeed my issue! After allowing editors to see all features, the geometry is displayed on the visualization tab and in the web map.

 

0 Kudos
MCameron
Esri Contributor

Hi @LinzMess 

Thanks for coming back and happy to hear that this has resolved the issue for you! This is a workaround to a known bug that we have logged internally (BUG-000150919). Based on this bug, we have found that this setting configuration is not preserved if you:

  1. Republish a survey from the ArcGIS Survey123 web app.
  2. Update the Survey123 configuration for "What submitters can do" under the collaboration tab in the ArcGIS Survey123 web app.

The bug status is marked as 'Under Consideration' and so it is likely to have an update sooner rather than later as to whether it will be fixed in the next release of ArcGIS Online. But please do keep this in mind if you are actively making changes to your survey, that you may need to repeat the workaround for the time being to make the layer visible to users in the web map again. 

0 Kudos