Advanced ArcGIS Online Search - keywords return strange results

325
2
Jump to solution
04-22-2020 06:10 PM
curtvprice
MVP Esteemed Contributor

I am having a heck of a time with advanced search.  I get the same results from Pro and arcgis.com. I would think I'd still be getting USA Major Roads from both searches. I tried owner:Esri and owner:esri. I've seen similarly weird results with type:"Feature Layer" - not seeing things that seem like they should come up.

Search 1:

search 1

Search 2:

search 2

0 Kudos
1 Solution

Accepted Solutions
TimOrmsby
Esri Regular Contributor

Hi Curtis, I don't have much to add, but I did notice one thing. If you go the item page of USA Major Highways you'll see that the owner is Esri (as shown in the search results) but the item is managed by esri_dm.

If you search for USA Major Highways owner:esri_dm (in ArcGIS Online or in Pro) the expected item is returned. 

Tim

View solution in original post

2 Replies
TimOrmsby
Esri Regular Contributor

Hi Curtis, I don't have much to add, but I did notice one thing. If you go the item page of USA Major Highways you'll see that the owner is Esri (as shown in the search results) but the item is managed by esri_dm.

If you search for USA Major Highways owner:esri_dm (in ArcGIS Online or in Pro) the expected item is returned. 

Tim

curtvprice
MVP Esteemed Contributor

That works for me too. Thank you - great tip. With COVID our students locked off campus and for bandwidth issues can't easily get data off our esridata folder, so this is really helpful!

Today type:"layer" and type:"layer package" seem to be working for me. I still think AGOL advanced searching needs more detailed documentation, for example a list of what type: keywords are supported, and whether "layer" and "layer package" are synonymous.

0 Kudos