ArcGIS Online Feature Service geodatabase export has some lost settings

712
1
03-09-2016 12:15 PM
Status: Open
BrianFausel
Occasional Contributor III

When exporting a hosted feature service from ArcGIS Online (AGOL) to a File Geodatabase (GDB), some of the key GDB settings that you originally set up are lost in the export. I have encountered this when feature services were originally created via ArcMap "Share as a Service" from a File GDB.  Please fix the AGOL export so that all of the original GDB settings are preserved in the downloaded File GDB.

Specific examples of settings that are lost:

1)  "Default Values" for all attributes of the feature class and related tables
2)  GDB "Domain Description" text
3)  Feature class that you export has a different name in the download GDB than it was in the original GDB
4)  Relationship Class(es) have different name(s) in the download GDB than in the original GDB
5)  Relationship Class "Notification" and "Label" settings are removed

6)  Subtypes

1 Comment
EmilyKuhn

I am running into these same problems (3 years after this was posted)

Upon looking through other GeoNet posts and troubleshooting documentation on exporting tables from AGOL, I have concluded that there does not seem to be a good work around.  Subtype and domain descriptions are unreliable and frequently lost when exported from AGOL to any other data table, geodatabase, or feature class file format.

This topic has been an ongoing issue for years...Does anyone have any advice?

(Other than exporting into a FGDB; this method does not work for me)

Any advice is greatly appreciated!