Add Records to ArcGIS Online Hosted Table

1246
7
11-29-2018 04:08 PM
Status: Open
Occasional Contributor

This idea might already be posted but I'll put it out there just in case it hasn't.  This week, we were trying to edit a standalone table that is hosted in ArcGIS Online.  We wanted to manually add a few records to a table but we couldn't do it from the Map interface or from the Data tab in the Item Details window.  Editing was enabled on the table.  The help document about editing tables in ArcGIS Online made no mention of manually adding records to a hosted standalone table.  My idea then is:

Allow a user, with the proper permissions, the ability to manually add records to a hosted standalone table in ArcGIS Online (this assume the table has editing enabled).

Thank you. 

7 Comments

This would be great to be able to do in Collector as well.

This would be a great feature to bring table functionality in line with feature layers. Here is a workflow where it would be useful:

Our department has a master parks layer which contains basic attribute information about the each park property. A team working on a planning project wants to be able to run analyses on various subsets of the parks data. As such, they create a standalone table with a row for each park where and columns denoting the subset of parks used for various analyses. That table is published as a hosted feature service on ArcGIS Online. By creating a join view between the authoritative parks dataset and their standalone table, they use the resulting view to run various analyses without affecting the authoritative parks dataset. A new park is added to the authoritative parks dataset, so a new row needs to be added to the standalone analysis configuration table. Currently this appears to only be possible via:

  • ArcGIS Pro: You can open the table in Pro and then add a new record. This is an incredibly heavy-weight solution for adding a new row to a table.
  • Appending updates from an uploaded CSV or JSON: This feels like a workaround at best and is an overkill for adding a couple rows now and again.
  • ArcGIS Python API: I think this could be done...but it feels like overkill.
  • ??? Some other method?

Joining spatial and non-spatial tables to one another is a common GIS and database task, but it feels like tables are being treated like tables are a bit of an afterthought. The capability to create views from table joins in ArcGIS Online has made tables a first-class item within AGOL. It is super-simple to add a new row to a feature layer. Give a little love to the tables!

How does this functionality not exist yet? I don't want to have to open the AGO table in Pro just to add a record.

Still not available? I want another user to be able to add records to a table that updates a dashboard without logging in as me and uploading a new excel file. I set up edit views with limited permissions for the tables but can't add a new record so I'm stymied in my workflow.

+1 for this idea, so tables and related tables can be updated

Please upvote this similar idea: Ability to add Related Records via Item Details Data tab 

Another use case: tables with metrics that populate a dashboard. These tables don't have a spatial component so you can't "create a new GIS feature" to add a new record. I'm trying to get the departments to be able to maintain their own dashboards, but they aren't GIS-savvy so trying to teach them Pro hasn't gone well and exporting the table, editing it, and reuploading it is time-consuming and confusing for them.

That's a great example of why we need this.  Thanks for posting to my idea!