Why does my location-allocation solve keep failing?

5081
4
07-09-2015 06:28 AM
MatthewTapley
New Contributor

Hi all,

Using the ArcMap 10.1 Network Analyst Location-allocation solver, I am attempting to allocate 171,126 Census Output Area centroids (demand points) to 2624 secondary school (facilities) using distance as impedance, school-age population as demand point weight and school capacity as facility capacity. The L-A problem type I am using is the "maximise capacitated coverage" problem type. I require all schools to be included in the solution so I have set the "facility type" as "required" and the number of "facilities to choose" to 2624.

When I run the solver, no error messages are initially displayed and the process appears to be working. Arc takes approximately 5 minutes to "Compute OD lines" for all objects. The editing of the OD cost matrix values for use in the location-allocation problem type then appears to be carried out in a minute or two. Following this, "Locating facilities" briefly flashes up next to the progress bar before "Solve failed" is displayed. No error messages are produced.

From looking into the algorithms used in the process, it would appear that the solve failure occurs at the stage of the operation where (to quote ESRI help: "the location-allocation solver then generates a set of semi-randomized solutions and applies a vertex substitution heuristic (Teitz and Bart) to refine these solutions creating a group of good solutions".

Is anybody able to explain what may be causing this error and perhaps suggest some way I may be able to get around it?

Cheers

4 Replies
JaySandhu
Esri Regular Contributor

You say you have 171,126 demand and 2624 facilities. The first thing that comes to mind is that it may not have sufficient RAM to complete this work. Do you specify any distance cutoff to limit the amount of demand each facility needs to evaluate? In case you have a 64 bit OS, can you use background 64 bit GP to solve the problem and see if you get an answer?

Jay Sandhu

MatthewTapley
New Contributor

Thank you for the response Jay.

The PC I'm working on has 16GB of RAM and have also tried expanding the virtual memory. I have tried running the operation both with a distance cutoff (25km) and without. The distance cutoff appears to initially increase the speed of the process but the solve still fails.

Will try using background 64 bit GP but first need to install Arc 10.2 (as currently on 10.1).

Thanks again.

Matt

0 Kudos
VirginiaBalbo
New Contributor

Hi Jay-

I am also experiencing failures running  a large location allocation analysis with 51 Facilities to service 380723 demand points.     I have set the cutoff minutes to 40 and the cutoff meters to 32,200.    Running in ArcMap 10.1 with 32 GB Ram, i7 processor.   When the solve is executed it runs for a while but returns the following along with a memory error.

I'm not fully familiar with 64 bit GP so appreciate some further information...  do you meanan ArcGIS Pro installation?

Thanks.

0 Kudos
JacobHelfman1
New Contributor III

This error was resolved on my end once I decreased the number of Facilities by 1. 

0 Kudos