Unable to change impedance

04-25-2011 06:42 AM
New Contributor
I am using Network Analyst for the first time and am trying to create a service layer.  Everything works well except that in the layer properties, I cannot change the Impedance from Length.  It needs to be the time and that choice is not available.  The network dataset has been built and I can create polygons based on distance without any issues.

Thanks in advance for any help.
Tags (2)
0 Kudos
3 Replies
Esri Regular Contributor
Most likely you have not added a travel time impedance attribute to your network dataset.
That is, the service area solver will give you an option to change the impedance attribute
to any of the supported attributes. So use ArcCatalog (or catalog in ArcMap 10) to bring up the
properties of the Network Dataset and click on the Attributes tab and see if you anything but
Length listed there. If not, you will have to add one, set its evaluators and Build the network
dataset again.

Jay Sandhu
0 Kudos
New Contributor
That did allow me to select a time attribute, but I obviously do not have the fields needed to create that sort of routing.  It bombs each time.  I need to do some more digging into the fields I actually need.  Thanks for your help and I will probably be back for more help.
0 Kudos
New Contributor
When you generate a new impedance field, you may use some standard names, such as miles, hour, minutes, meters, and so on.
It might help you to set up impedance since the network analyst realize them automatically while setting up parameters of the network analyst.
0 Kudos