Solving Route: Stay time

1177
4
12-21-2016 08:09 AM
Highlighted
by
Occasional Contributor III

Hi,

beside the "time window" option that doesn't work for me.

How can I set a "stay time" let's a minute for each stop?

The analysis I am running now doesn't consider this, in fact the total time is too short compared to the reality.

Sorry for the poor question but I am a newbie with NA.

Thanks.

Reply
0 Kudos
4 Replies
Highlighted
Esri Contributor

We were all newbies at some point, so don't feel bad.

I'm assuming that you're doing a Vehicle Routing Problem, but please correct me if I'm wrong. If you are doing a VrP, then you can use the ServiceTime property on the Orders to do this. According to the documentation Vehicle routing problem analysis—Help | ArcGIS Desktop , ServiceTime "specifies how much time will be spent at the network location when the route visits it; that is, it stores the impedance value for the network location. A zero or null value indicates the network location requires no service time."

So if you want 10 minutes to be spent at each order, you can either set the default service time to 10 when loading the order locations or you can have a field called ServiceTime on the feature class that will be used for the orders and just fill in the value for each order.

Hope this helps, but let me know if I missed something

Highlighted
by
Occasional Contributor III

Thank you!

I am having a look and I'll let you know!

Reply
0 Kudos
Highlighted
by
Occasional Contributor III

Hi Rachel,

I'm replying late.

So, I needed to set that value for a simple route, no VRP.

Anyway after having had a better look I could find the way.

The field Attr_minutes needs to be filled either loading the staying time when you upload your stops (if you have a field with that value) or setting a default value in the route properties if the Attr_minutes is empty.

Then you set the impedance to Minutes and you got the route solved by considering that timewindow.

Thank you for your help, as I have to work with VRP later on I will be using your advice!

Reply
0 Kudos
Highlighted
by
Occasional Contributor III

Hi Rachel,

I'm replying late.

So, I needed to set that value for a simple route, no VRP.

Anyway after having had a better look I could find the way.

The field Attr_minutes needs to be filled either loading the staying time when you upload your stops (if you have a field with that value) or setting a default value in the route properties if the Attr_minutes is empty.

Then you set the impedance to Minutes and you got the route solved by considering that timewindow.

Thank you for your help, as I have to work with VRP later on I will be using your advice!

Reply
0 Kudos