Road Networks in SDE

135
5
05-06-2020 07:24 AM
melisahansen
New Contributor III

I have been doing a lot of testing with a road network in SDE. It has been extremely buggy. Lots of errors and issues that don't usually occur if the network is in a file geodatabase. Is SDE not capable of dealing with a maintained network? 

0 Kudos
5 Replies
MelindaMorang
Esri Regular Contributor

I'm sorry to hear you've been experiencing problems with network datasets in SDE.  This workflow is supported.  If you can describe in detail the problems you're experiencing or call Esri's Technical Support to report them, we can get them fixed.

0 Kudos
melisahansen
New Contributor III

One of the biggest issues is rebuilding it. Sometime when you rebuild it most existing edges disappear and make the network unusable. Another big issue is using it in a versioned environment. A built network does not post as built so any changes don't get recognized in the parent version, which makes it not routable. Any suggestions or solutions? 

0 Kudos
MelindaMorang
Esri Regular Contributor

This sounds sort of hard to diagnose by GeoNet, but it definitely sounds like a problem we ought to look into.  I suggest you call Support.  They can work with you to either resolve the issue, or they can but it together into a bug report so we can fix it.

Out of curiosity, are you accessing your SDE network dataset through ArcMap or ArcGIS Pro?

0 Kudos
melisahansen
New Contributor III

Both in ArcMap and ArcGIS Pro. The issues are common in both but, ArcGIS Pro we are having a lot more issues with. 

0 Kudos
JoeBorgione
MVP Esteemed Contributor

I've always been of the opinion that feature datasets misbehave in the enterprise environment, so I've avoided them. 

What advantage do you see keeping it in the enterprise environment?

can't wait to retire....
0 Kudos