problem with creating a new Travel Mode in Pro

08-06-2020 12:02 PM
New Contributor III

I have tried to create a new travel mode and have not been able to save it - how do I save the new travel mode? I followed the documentation for Pro 2.5 to create a new travel mode - from the Properties of the network dataset, select the Options buttonMenuClick the New button, change the name to a test it - Travel Mode Test, then Click OK to close the Network Dataset Properties dialog box. When I go back into the properties of the network dataset, there is no travel mode. Is there something else I need to do to save the new mode?  Thanks!

0 Kudos
2 Replies
Esri Regular Contributor

I think you're running into a known issue that we fixed in the ArcGIS Pro 2.6 release.  We saw this behavior when trying to add travel modes to an old network dataset.  If you open the network dataset properties to the General tab and expand the Summary section, I'm guessing you will see that the dataset version is 9.3 or something like that (ie, not 10.1, which is the latest version for network datasets).

You have two options to work around this problem:

1) Install ArcGIS Pro 2.6 (I saw from your other post that you said you're using 2.5).  The problem should be gone in 2.6.

2) Use the Upgrade Dataset geoprocessing tool to upgrade the network to the latest dataset version.  I think this will also fix the problem.

Let me know if neither of those options resolves the issue.

New Contributor III

Upgrade Dataset tool worked, thanks!

0 Kudos