Select to view content in your preferred language

OD Cost Matrix tool not connecting to my network dataset for travel mode

702
2
12-08-2022 12:28 PM
Labels (2)
AmberMillison
Occasional Contributor

Hello, I am trying to run several OD Cost Matrix analyses using the Network Analyst package. I was able to successfully run it once based on a network dataset I created from my local roads layer in addition to my own origin and destination point layers. However, the tool only works for a maximum of 1000 origin points, but I need to perform this analysis on around 3,000 origin points (against only 5 destination points). Because of this, I separated out my origin point layer into three groups. As I said, the first group ran successfully and I was able to generate travel times (in minutes) for all my points in that layer. However, I tried to create a new OD Cost Matrix layer for the rest of my origin points, set up the tool and inputs exactly the same as before, but now for some reason I am unable to select a Mode (Driving time, driving distance, etc). Instead, the Mode window just says "<custom>, ft" with no ability to select from the drop-down menu - even though I have the exact same network dataset layer added into the map. I have retried running the tool both on the same map, as well as on a new map, and I've also tried recreating an identical feature dataset containing an identical network dataset, but I cannot get the tool to let me select my preferred travel mode (drive time in minutes). When I hover over the Mode, it says "This command is currently unavailable. The current network data source does not have any travel modes". I just don't understand how it worked the first time but not when I try again using the exact same inputs and parameters? Has anyone run into a similar problem, and/or found a solution to this? Is there some place I can directly connect my network dataset into the OD cost matrix layer aside from simply having them contained in the same map to ensure that the travel mode can be based off my network dataset?

0 Kudos
2 Replies
JaySandhu
Esri Regular Contributor

It is hard to say what may be going on. But let's start with looking at the properties of your network dataset in the Catalog pane. On the traffic attributes you should be able to see if you have travel modes like so:

JaySandhu_0-1670627119934.png

 

If you do see your expected travel modes then I suggest starting a new project in Pro, adding your network dataset and then creating the OD Cost Matrix layer. Does the ribbon at this point show you your travel modes? If yes, then you can continue with loading your locations.

If not, then we have to diagnose it more on what could be going on.

Regards,

Jay Sandhu

0 Kudos
MelindaMorang
Esri Regular Contributor

It's hard to tell what's going on.  If you're seeing a message about a 1000-point limit, then you are probably (intentionally or unintentionally) using the ArcGIS Online services as your network data source. It sounds like you were possibly using your own network dataset when you tried to rerun the analysis, and your network doesn't have any travel modes (hence the <Custom> Mode name).

This documentation shows how to set the network data source when you create a new network analysis layer: https://pro.arcgis.com/en/pro-app/latest/help/analysis/networks/new-network-analysis-layer.htm

If this doesn't help, please clarify your question and we'll take it from there!

0 Kudos