Navigator map download fails.

1206
4
Jump to solution
02-14-2017 12:46 PM
MatthewKauth2
New Contributor

Hi, I have created an mmpk for Navigator. When I open the map in Navigator I receive the following message, "This map is not compatible with this version of Navigator. Please update the mobile map package." I am using Navigator 2.0 and creating the map package with Arc PRO 1.4

0 Kudos
1 Solution

Accepted Solutions
MarkBockenhauer
Esri Regular Contributor

Thanks Matthew,   We need to do a better job with our error messages or letting you know what Navigator wants in the MMPK.  Your MMPK only has a network dataset in it,  Navigator is expecting at least one feature layer.  If you add a feature layer to to your map for the Naperville extent, Navigator will be able to open the map.

However, routing will not calculate for your network.  Navigator is also expecting a Travel Mode to be defined for the network dataset, so you will have to add that as well.

I will write this up for the Navigator team... to get the experience improved in a future release.

Thanks for the feedback,

Mark

View solution in original post

0 Kudos
4 Replies
MarkBockenhauer
Esri Regular Contributor

To know for sure I would need to look at the MMPK,    Is it possible to share it or a sample (package a small portion of the source map)?

Thanks,
Mark 

0 Kudos
MatthewKauth2
New Contributor

Hi, Mark. Thanks for the reply. I couldn’t see where to attach a file when replying via geonet so am emailing directly.

The MMPK I used is attached.

Thanks

Matt

Matt Kauth

GIS Analyst

Geospatial Software Development Team

55 E. Monroe St., Suite 3450, Chicago, Illinois 60603

P 312-201-7961 | C 708-227-0171 | F 312-220-0722

mkauth@patrickco.com<mailto:mkauth@patrickco.com> | www.patrickco.com

0 Kudos
MarkBockenhauer
Esri Regular Contributor

Thanks Matthew,   We need to do a better job with our error messages or letting you know what Navigator wants in the MMPK.  Your MMPK only has a network dataset in it,  Navigator is expecting at least one feature layer.  If you add a feature layer to to your map for the Naperville extent, Navigator will be able to open the map.

However, routing will not calculate for your network.  Navigator is also expecting a Travel Mode to be defined for the network dataset, so you will have to add that as well.

I will write this up for the Navigator team... to get the experience improved in a future release.

Thanks for the feedback,

Mark

View solution in original post

0 Kudos
MatthewKauth2
New Contributor

Thanks, Mark.  Adding the feature layer did the trick!

0 Kudos