DllNotFoundException: libruntimecore - Issue only in built application not editor.

486
2
02-08-2023 01:31 PM
Michael_Morg
New Contributor

Hi there!

I'm running into an issue just the samples provided by the base ArcGIS for Unity package (Also when trying to use it inside my own application). All of the different sample scenes work inside the editor as intended. When the samples are built into a regular desktop application I get constant errors and nothing from ArcGIS appears on the screen:

Screenshot 2023-02-09 at 10.27.54 AM.png

They don't all come from the same place (i.e. some come from ArcGISCameraControllerComponent.cs but others from ArcGISLocationComponent.cs) but they all result in a DllNotFoundException: libruntimecore.

Could this potentially be hardware related? I'm running this on an M1 Macbook but with the Intel version of the Unity Editor.

I'd appreciate any help, thanks.

0 Kudos
2 Replies
and1
by Esri Contributor
Esri Contributor

Hi, we tried building one of the sample scenes (Component Global Sample) on a machine with the M1 chip + Intel version of Unity but could not reproduce the error message. Since it's the Intel version of Unity editor, in the Build Settings we selected "Intel 64-Bit" for the Architecture option and the build was successful with the map data shown in the build application. Could you try this out and let us know if it works out for you?

Screen Shot 2023-02-13 at 12.02.23 PM.png

0 Kudos
AviBar-Zeev
New Contributor

I got the same error on an M1 Mac, but it happened when using the Apple Silicon version of Unity 2021.3.19f1 and any combination of build settings for "architecture" (intel, Apple, both). But switching to the Intel build of Unity works for the sample project. Could you verify that the Apple Silicon version of Unity + Apple Silicon build settings works for you too on a clean install?

0 Kudos