Zone Lookup Template won't allow configuration

376
3
Jump to solution
11-13-2021 09:14 AM
Labels (1)
ahargreaves_FW
Occasional Contributor III

Hello

I've map a simple map and shared it to the Zone LookUp template. However I can't configure the app. Whenever I try to do so I get the below URL but just a blank, white page.

https://myorgname.maps.arcgis.com/apps/configure-template/index.html?appid=MyAppIDNumber

0 Kudos
1 Solution

Accepted Solutions
ahargreaves_FW
Occasional Contributor III

If anyone else is experiencing issues not being able to configure AGOL apps the reason may be that access to the ESRI JS CDN was blocked by our IT dept. Official URL Whitelist can be found attached to this posting.

#Whitelist #CDN #JS.api #ConfigurableApps

View solution in original post

0 Kudos
3 Replies
ahargreaves_FW
Occasional Contributor III

If anyone else is experiencing issues not being able to configure AGOL apps the reason may be that access to the ESRI JS CDN was blocked by our IT dept. Official URL Whitelist can be found attached to this posting.

#Whitelist #CDN #JS.api #ConfigurableApps

0 Kudos
KellyHutchins
Esri Frequent Contributor
I just ran a few tests and am not able to reproduce the issue. Can you provide more details about your map for example types of layers you have included? Also if you are able to run the configuration experience with the developer tools open can you check to see if there are any error messages listed? Here’s some info on opening the developer console if you haven’t done so before:

https://balsamiq.com/support/faqs/browserconsole/#:~:text=To%20open%20the%20developer%20console,(on%...).




0 Kudos
ahargreaves_FW
Occasional Contributor III

Hello @KellyHutchins 

I answered my own posting above and here. The issue was that I could not access the configuration experience at all as our IT dept was blocking access to an ESRI CDN that provided access to JS services. After whitelisting these and others in the doc listed above I had no issues. Below is a screenshot of the chrome developer console error if the various URLs are not whitelisted.

ahargreaves_FW_0-1637070917933.png

Thanks

Andrew

0 Kudos