Zone Lookup Issues

1125
10
12-05-2019 02:49 PM
EricBregant2
New Contributor II

Is there a way to order layers in a preferred way? The app seems to order them randomly. Even if I order them how I want in the web map, they still do not order correctly.

Also, the "Use Current Location" widget is not available on this app even though it is mentioned in the default welcome text.

Can this be corrected?

10 Replies
KellyHutchins
Esri Frequent Contributor

The use current location included with the search widget is only available when the app is accessed via https.  

0 Kudos
JenAmes
New Contributor III

Did you ever get a response on how to reorder the layers? I assumed the returned information would reflect the way the layers are organized in the map the app is based on, but that does not appear to be the case. Which is dumb.

0 Kudos
KellyHutchins
Esri Frequent Contributor

We recently added an update to the app and the layers should now be in the map order 

0 Kudos
JenAmes
New Contributor III

My layers are still not showing up in the order I have them on the map. They're actually showing up in almost the exact opposite order that I want them in, except if I adjust the order they show up on the map, they still don't change their order in the app. Am I missing something?

0 Kudos
KellyHutchins
Esri Frequent Contributor

Is your app/map public? If so can you either post the link here or email me at khutchins@esri.com so I can take a look? 

0 Kudos
JenAmes
New Contributor III

It is public, I sent you an email with the links.

0 Kudos
MattRichardson
New Contributor II

Hi JenAmes,

Did you ever get a resolution to this? I am having the same issue.

0 Kudos
JamesTanis
New Contributor

Is there any update to this?  The layers are not returned in the results in the order they are in the map.

0 Kudos
MattRichardson
New Contributor II

Unfortunately not. I called support and talked to someone and they were unsure of the reason why the order of the layers in the map didn't match the order of the layers in the app, and was unsure why there was no option to move the layer order in the results. He was transferring to another analyst, but got disconnected in the process (suddenly just heard dial tone), unfortunately not the first time for that. I haven't gotten back to this, but will post if i figure anything out.