Invalid redirect_uri Error: 400

3585
3
Jump to solution
10-02-2017 06:21 AM
LaszloCsunderlik1
New Contributor III

When I try to launch the Insights for ArcGIS from my Portal I get the Invalid redirect_uri Error: 400 . 

Same problem and message if I try to open a workbook or a page from the Portal.

I am using:

  • ArcGIS10.5 environment,
  • federated server
  • data store are configured too
  • One webadaptor successfully configured with my portal
1 Solution

Accepted Solutions
AravindStoryMaps
Esri Regular Contributor

Hey Laszlo, 

Thanks for making a post here. I just wanted to give you an idea of the minimum requirements for Insights for ArcGIS based on what you've provided here for me: 

1. Base Enterprise ArcGIS Deployment

  • ArcGIS Server—This ArcGIS Server must be licensed as ArcGIS GIS Server Standard or ArcGIS GIS Server Advanced and configured as the hosting server for your portal.
  • Portal for ArcGIS.
  • ArcGIS Data Store—Upon setup, this should be configured as a relational and tile cache data store.
  • ArcGIS Web Adaptor—One Web Adaptor installation for traffic to your portal and one for traffic to your ArcGIS GIS Server.

I would verify if you installed one more web adaptor for ArcGIS Server, since you'd mentioned just Portal for ArcGIS in your notes above. 

Additionally 

I'd also verify the following in the Portal for ArcGIS Administrator directory.

  1. You can go to this URL: https://<URL to Portal>/WebAdaptorName/portaladmin.
  2. After you've logged in as the administrator directory, go to https:///<URL to Portal>/WebAdaptorName/portaladmin/security/oauth/getAppInfo
  3. In the textbox for this page, type "arcgisInsights" and retrieve getAppInfo for this page.
  4. This should contain a number of hostnames that the app typically redirects to under the "redirectURIs" parameter. Make sure that your <URLtoPortal> is listed here for both protocols HTTP & HTTPS.
  5. If they're not listed, copy the value obtained from getAppInfo and go into updateAppInfo and paste the value in there and specify HTTP://<URLtoPortal> as the value and then save.
  6. Now go back to Insights home page and please let me know if you were able to use the app now without the 404 error.  

Please let me know if these steps worked for you. 

Thanks,

Aravind

View solution in original post

3 Replies
AravindStoryMaps
Esri Regular Contributor

Hey Laszlo, 

Thanks for making a post here. I just wanted to give you an idea of the minimum requirements for Insights for ArcGIS based on what you've provided here for me: 

1. Base Enterprise ArcGIS Deployment

  • ArcGIS Server—This ArcGIS Server must be licensed as ArcGIS GIS Server Standard or ArcGIS GIS Server Advanced and configured as the hosting server for your portal.
  • Portal for ArcGIS.
  • ArcGIS Data Store—Upon setup, this should be configured as a relational and tile cache data store.
  • ArcGIS Web Adaptor—One Web Adaptor installation for traffic to your portal and one for traffic to your ArcGIS GIS Server.

I would verify if you installed one more web adaptor for ArcGIS Server, since you'd mentioned just Portal for ArcGIS in your notes above. 

Additionally 

I'd also verify the following in the Portal for ArcGIS Administrator directory.

  1. You can go to this URL: https://<URL to Portal>/WebAdaptorName/portaladmin.
  2. After you've logged in as the administrator directory, go to https:///<URL to Portal>/WebAdaptorName/portaladmin/security/oauth/getAppInfo
  3. In the textbox for this page, type "arcgisInsights" and retrieve getAppInfo for this page.
  4. This should contain a number of hostnames that the app typically redirects to under the "redirectURIs" parameter. Make sure that your <URLtoPortal> is listed here for both protocols HTTP & HTTPS.
  5. If they're not listed, copy the value obtained from getAppInfo and go into updateAppInfo and paste the value in there and specify HTTP://<URLtoPortal> as the value and then save.
  6. Now go back to Insights home page and please let me know if you were able to use the app now without the 404 error.  

Please let me know if these steps worked for you. 

Thanks,

Aravind

View solution in original post

LaszloCsunderlik1
New Contributor III

Hello Aravind,

Thanks for your answer, I went through all the steps and now I can open the workbook from the portal and I can launch the Insights from the Apps. 

AravindStoryMaps
Esri Regular Contributor

Hello Laszlo, 

Thank you for confirming this. We'd also appreciate it if you can resolve this thread as solved and mark the correct answer so everyone can benefit from this resolution. 

Have a great week!

Aravind