Open Data website & PDF iFrames

397
10
04-11-2019 06:11 AM
AndrewNichols1
New Contributor II

Hello. We are experiencing some interesting behavior on our Open Data website and was hoping someone would have some insight.

We have a collection of Static Maps uploaded as PDFs to ArcGIS Online and Shared with our Open Data Group. When you go to the item in the Open Data site only a small portion of the pdf is visible (see image 1). Is this normal behavior for an Open Data Site? In the Open Data Settings; Under the Capabilities tab I toggled on and off the "Document iFrames" option but saving and refreshing the site has no effect.

10 Replies
PatrickHammons1
Esri Contributor

Hi Andrew,

The incredibly small preview pane is a known bug we are working to resolve. I'll let you know when we have a fix out.

As to the preview capability you toggled, there should be a difference in functionality. When that capability is turned on, the item page loads and previews the document in the preview pane. When it is toggled off, then the document will load directly from the search results page, as DC has chosen to do: http://opendata.dc.gov/search?collection=Document

Try toggling again and reply back if it's not working as expected.

Best,

Patrick

0 Kudos
AndrewNichols1
New Contributor II

Hey Patrick!

I tried toggling the "Document iFrames" option on\off again but still don't see any changes in how pdfs open. Is it possible that the issues comes from our pdfs and site pages being part of our ArcGIS online organization? This seems  different than the DC example you provided, which seem to link to google drive. 

0 Kudos
PatrickHammons1
Esri Contributor

Hi Andrew,

No, there shouldn't be an issue regarding hosting. One usability issue we've noticed with the site admin is that you have to hit save after you toggle the options on, which is an easy step to miss. Is that possibly the issue?

Patrick

0 Kudos
AndrewNichols1
New Contributor II

Hey Patrick!

I wish it were that simple, but no. I was very careful to save my changes after toggling the options.

0 Kudos
PatrickHammons1
Esri Contributor

Hi Andrew,

Looks like we have a bug. I was able to reproduce on our end and it looks like disabling document preview is broken. We're working on a fix and will let you know when it's out.

Best,

Patrick

0 Kudos
AndrewNichols1
New Contributor II

Great! Thanks a lot Patrick! I appreciate your quick work on this. 

0 Kudos
PatrickHammons1
Esri Contributor

Wanted to give an update that we have resolved this issue. Try it out on your site and let me know if you continue to see any problems with the document preview toggle.

0 Kudos
AndrewNichols1
New Contributor II

Hey Patrick!

Sorry the delay in responding. I am still having an issue with this though. Our Open Data site is now public and here is the link...http://data-ptbo.opendata.arcgis.com/

This morning I tried toggling the "Document iFrames" button on and off again with no difference in how the PDFs were displayed.

Do you think it would be beneficial to create a support ticket and have someone look at the settings "behind the scenes"?

0 Kudos
AshleyHayes2
New Contributor III

Hi Patrick, I am having this issue.  I have toggled on and off the preview (save and publish) and it makes no difference.  I always get preview.  You mentioned it was resolved, though Andrew mentioned below that maybe it is now for him either.  Can you provide an update?

0 Kudos