Logging into Hub using SAML

460
3
08-06-2021 12:23 PM
Katelyn1
New Contributor II

Hi,

 

We are using Hub for creating sites for internal users to have curated content. We are running into issues with the login process because there are many steps & it isn't intuitive for a non-GIS person. After you press the Sign In button it takes you to another page where you can enter credentials or choose to go to your organizations URL. The regular ArcGIS Login was the option expanded at first and a number of folks have just started entering their AD credentials in that box and then it doesn't work. For a lot of folks they didn't know to choose the ArcGIS Organizations URL. Has anyone had any luck finding work arounds for this? My audience is executives at my company so I need it to be as few steps as possible.

Thanks for any help you can provide!

Tags (3)
0 Kudos
3 Replies
DavidSemitekol4
Occasional Contributor

Hi Katelyn, we just started using SAML at our organization.  I have the same type of users as you do.  What I did was first set up their organization account through my ArcGIS Online (AGOL) portal.  I then either sent them their invitation email or, if I was standing behind their shoulder, emailed them a link to our AGOL portal.  I had them open this link first to establish the account and then I emailed them a direct link to the Hub site that I wanted them to use.  Going forward they only have to click on the link to the hub site and you can even create a desktop icon for them.  So far so good but if I run across any issues from my users I'll post an update.  We run an Azure AD system over here so Edge seems to be working the best when it comes to remembering user's credentials.

 

Hope this helps.

0 Kudos
Katelyn1
New Contributor II

Thank you for the quick reply! We are also using Edge, although we haven't switched to Azure AD yet. The items they are trying to access through the Hub are Story Maps. We're finding that even if it shows they are logged in to the Hub, they still have to enter their credentials to access the Story Map. What are your folks accessing?

0 Kudos
DavidSemitekol4
Occasional Contributor

That is interesting and unfortunate.  The only other recommendation I can make is to create a group in AGOL, add the hub and the storymaps to the group along with your users.  It is strange that once your users are logged into the hub that they need to enter credentials again for the story map.  If all else fails you can log a case with ESRI technical support.  I've had good experiences with them in the past.  Best of luck!

0 Kudos