Error adding members (community users) to Supporting Team

1003
23
04-29-2021 06:05 AM
DataOfficer
Occasional Contributor III

We have created a Supporting Team for one of our ArcGIS Hub initiatives. We have Hub Premium and have invited some of our community members to the team. Some get added to the group but without the invite message, whereas for others we are getting an error and they are not being added at all.

I have tested 2 routes for adding the community users that throw the error to the group, with the following behaviour:

  • Via the hub initiative supporting team page - red bar appears at the bottom after sending invite saying 'an error occurred'. No other error information. Despite writing an invite message, the message is not being delivered but the user is being added to the team.
  • Via ArcGIS Online - logged in with the Community Admin account - Error adding members. The following members could not be added to this group. They may not have the privileges needed to join the group or may have hit the maximum number of groups (512).

In both cases I am either the group owner or assigned as a manager.

All users are Creator user types with User roles. Profile visibility is set to Organization, and users are only members of 1 or 2 groups.

Group settings are as follows:
Who can be in this group? Any organization's members

How can people join this group? By invitation

Who can view this group? Only group members

Who can contribute content? Group owner and managers

 

I've been unable to find a relevant solution in the technical article on this error.

23 Replies
JayantaPoddar
MVP Esteemed Contributor
0 Kudos
DataOfficer
Occasional Contributor III

Thanks Jayanta. I have checked that article (and linked to it in my original post). However, it does not explain the behaviour I am experiencing nor resolve it unfortunately.

0 Kudos
KatelynThompson
Esri Contributor

Hi - You mention that you're using the community administrator account for one of the scenarios. Can you tell us what account you're using in Hub?  This will help us to narrow in on a solution 🙂

Katie 

0 Kudos
DataOfficer
Occasional Contributor III

Hi @KatelynThompson
I hold both the organisational admin and the community admin accounts. I first log in to hub using my organisational account, navigate to the initiative, select the Teams option from the dropdown, and open the supporting team of interest. I then click on the Add Members icon and select My Community to choose from the list of community users. In some circumstances I am prompted to log in with my community admin to gain access to the list of community users, but it is not asking me to do that in this instance.

When adding from ArcGIS Online I get the same error that Susannah has attached in her post.

0 Kudos
JayDev
by Esri Contributor
Esri Contributor

Hi @DataOfficer, thanks for notifying us of the behavior that you're seeing. If you are using an organizational admin account, you should be able to successfully add users from your primary organization and community organization. If you aren't being prompted to log-in with a community admin account when trying to Add Members, it means you are already logged in.

We are currently working the resolve the two issues that you outlined above. 

0 Kudos
DataOfficer
Occasional Contributor III

Hi @JayDev, are there any updates on these issues?

0 Kudos
WilliamSimper_WDFW
New Contributor II

Changing the User Role of the Hub Accounts that we were trying to add from 'Data Editor' to 'User' allowed them to be added to the Supporting Team. I then manually changed them back to Data Editor so as to restrict their content creation abilities. ESRI staff notified us that this should be fixed in future updates.

0 Kudos
JayDev
by Esri Contributor
Esri Contributor

Hi @DataOfficer, we've remedied the issue that you mentioned in your first bullet point (where you saw conflicting error messaging in Hub's interface). You'll be prompted to write and send an invitation message when you are inviting community organization members while logged in as the community admin (if you aren't being prompted when you've selected the 'My Community' filter, that means you're already logged in).

The second bullet point that you identified adding community users via ArcGIS Online is under review by the ArcGIS Online team. As William mentioned below, if those accounts have the default 'User' role (as you mentioned above), they should have sufficient privileges to join the group. You should still be able to invite these community users to your supporting teams via Hub, or by de-selecting this option at the bottom of the Invite Users window in ArcGIS Online.

JayDev_2-1621963311636.png

 

0 Kudos
JayDev
by Esri Contributor
Esri Contributor

If you're continuing to see errors while trying to invite users with community accounts via Hub, send me a direct message and we can try to identify the issue on a call.

0 Kudos