Dataset showing up twice

514
16
10-23-2017 08:11 PM
MalcolmJacobson
Occasional Contributor II

Hi

I'm setting up our version 2 Open Data site and I'm having an issue where a dataset is showing up twice in the datasets list.

https://newversion-marlborough.opendata.arcgis.com/datasets?q=total%20control&sort=name 

Both results point at the same ArcGIS Online item https://www.arcgis.com/home/item.html?id=a56ff59d1f8645e188b052f0e96e3789

I've tried unsharing and resharing it again, and reindexing. What else could I try?

Thanks

Malcolm

0 Kudos
16 Replies
CourtneyClaessens
Occasional Contributor III

Hi Malcolm, 

We're taking a look. I'll update here soon. 

Courtney 

0 Kudos
MalcolmJacobson
Occasional Contributor II

Thanks Courtney

0 Kudos
MalcolmJacobson
Occasional Contributor II

Looks like its been fixed (not sure if it was something you did or not though!)

Is there a way to avoid this occuring or is there anything I might have done to make it show up twice?

Thanks

0 Kudos
CourtneyClaessens
Occasional Contributor III

We did remove them from the database. This has happened in the past when the ArcGIS Online item's underlying service URL is changed; that bug might have popped up again. Is there anything you recall doing that's out of the ordinary workflow? 

0 Kudos
MalcolmJacobson
Occasional Contributor II

I think I did change the service URL for that dataset. I've done that before and usually I unshare the dataset, change the URL and then share it again and re-index etc.

Would it be better to avoid doing that and create a new item instead and then delete the old one?

0 Kudos
MalcolmJacobson
Occasional Contributor II

That dataset is showing up twice again!

https://newversion-marlborough.opendata.arcgis.com/datasets?q=total%20control&sort=name

Both looking at the same item

http://marlborough.maps.arcgis.com/home/item.html?id=a56ff59d1f8645e188b052f0e96e3789

I do recall what change I made this time though, about a week ago I updated the Access and Use Constraints section in the ArcGIS Online item

0 Kudos
MalcolmJacobson
Occasional Contributor II

In an attempt fix this, I've deleted the AGOL item causing the issue and have created a new one looking at the original dataset. Hopefully this will sort it.

0 Kudos
CourtneyClaessens
Occasional Contributor III

Hi Malcolm, 

I see the dupe is still there - we're looking into it. 

Thank you for your patience and communication. 

Courtney

MalcolmJacobson
Occasional Contributor II

Just a small change, we're now using the version 2 open data site so the URL to see the duplicated datasets is now https://data-marlborough.opendata.arcgis.com/datasets?q=total%20control 

Still seeing the duplicate dataset.

Thanks

0 Kudos